Removal of e-Tugra root certificate
CVE-2023-37920GHSA-xqr8-7jwr-rhp7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (certifi 2023.7.22), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI certifi
- Affected
- >= 2015.4.28, < 2023.7.22
- Fixed in
- 2023.7.22
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-xqr8-7jwr-rhp7 lists affected ranges: PyPI certifi >=2015.4.28 <2023.7.22 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xqr8-7jwr-rhp7 lists affected ranges: PyPI certifi >=2015.4.28 <2023.7.22
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2023-37920: 0.57% estimated exploitation activity in the next 30 days; percentile 47.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Certifi 2023.07.22 removes root certificates from "e-Tugra" from the root store. These are in the process of being removed from Mozilla's trust store. e-Tugra's root certificates are being removed pursuant to an investigation prompted by reporting of security issues in their systems. Conclusions of Mozilla's investigation can be found here.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-xqr8-7jwr-rhp7
- Revision 1 · created ·
Published from osv record GHSA-xqr8-7jwr-rhp7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-37920 Advisory: Removal of e-Tugra root certificate IDs: CVE-2023-37920, GHSA-xqr8-7jwr-rhp7 Record: https://patchnext.com/advisories/cve-2023-37920 (revision 2, source checked 26 Oct 2026, 13:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: certifi 2023.7.22. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI certifi: affected >= 2015.4.28, < 2023.7.22; fixed in 2023.7.22 ## Suggested inspection (read-only) - `python -m pip show certifi`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on certifi. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-xqr8-7jwr-rhp7 (OSV record GHSA-xqr8-7jwr-rhp7 lists affected ranges: PyPI certifi >=2015.4.28 <2023.7.22 (fixed)) - Verified: https://github.com/advisories/GHSA-xqr8-7jwr-rhp7 (GitHub-reviewed advisory GHSA-xqr8-7jwr-rhp7 lists affected ranges: PyPI certifi >=2015.4.28 <2023.7.22) Commands are suggestions: review each one before running it.
Loading voting…