Skip to content

← Actionable
Medium, CVSS 6.8

Dapr API token authentication bypass in HTTP endpoints

CVE-2023-37918GHSA-59m6-82qm-vqgj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/dapr/dapr 1.11.2, 1.10.9), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.8 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:N/A:N
EPSS
  • CVE-2023-37918: 1.40% estimated exploitation activity in the next 30 days; percentile 72.46 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A vulnerability has been found in Dapr that allows bypassing API token authentication, which is used by the Dapr sidecar to authenticate calls coming from the application, with a well-crafted HTTP request. Users who leverage API token authentication are encouraged to upgrade Dapr to 1.10.9 and 1.11.2. Impact This vulnerability impacts Dapr users who have configured API token authentication. An attacker could craft a request that is always allowed by the Dapr sidecar over HTTP, even if the dapr-api-token in the request is invalid or missing. Patches The issue has been fixed in Dapr 1.10.9 and 1.11.2. Details When API token authentication is enabled, Dapr requires all calls from applications to include the dapr-api-token header, with a value matching what's included in the Dapr's configuration. In order to allow for healthchecks to work, the /v1.0/healthz and /v1.0/healthz/outbound HTTP APIs are excluded from the API token authentication check, and are always allowed. Dapr <=…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-59m6-82qm-vqgj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-37918

Advisory: Dapr API token authentication bypass in HTTP endpoints
IDs: CVE-2023-37918, GHSA-59m6-82qm-vqgj
Record: https://patchnext.com/advisories/cve-2023-37918 (revision 1, source checked 26 Oct 2026, 15:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/dapr/dapr 1.11.2, 1.10.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/dapr/dapr: affected >= 1.11.0, < 1.11.2; < 1.10.9; fixed in 1.10.9, 1.11.2

## Suggested inspection (read-only)
- Go github.com/dapr/dapr: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/dapr/dapr.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-59m6-82qm-vqgj (GitHub-reviewed advisory GHSA-59m6-82qm-vqgj lists affected ranges: Go github.com/dapr/dapr >=1.11.0 =0 <1.10.9)

Commands are suggestions: review each one before running it.

Loading voting…