KubePi Privilege Escalation vulnerability
CVE-2023-37917GHSA-757p-vx43-fp9r
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/KubeOperator/kubepi 1.6.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/KubeOperator/kubepi
- Affected
- < 1.6.5
- Fixed in
- 1.6.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-757p-vx43-fp9r lists affected ranges: Go github.com/KubeOperator/kubepi >=0 <1.6.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:H/A:L
- EPSS
- CVE-2023-37917: 0.74% estimated exploitation activity in the next 30 days; percentile 54.75 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A normal user has permission to create/update users, they can become admin by editing the isadmin value in the request PoC Change the value of the isadmin field in the request to true: https://drive.google.com/file/d/1e8XJbIFIDXaFiL-dqn0a0b6u7o3CwqSG/preview Impact Elevate user privileges
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-757p-vx43-fp9r
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-37917 Advisory: KubePi Privilege Escalation vulnerability IDs: CVE-2023-37917, GHSA-757p-vx43-fp9r Record: https://patchnext.com/advisories/cve-2023-37917 (revision 1, source checked 26 Oct 2026, 15:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/KubeOperator/kubepi 1.6.5. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/KubeOperator/kubepi: affected < 1.6.5; fixed in 1.6.5 ## Suggested inspection (read-only) - Go github.com/KubeOperator/kubepi: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/KubeOperator/kubepi. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-757p-vx43-fp9r (GitHub-reviewed advisory GHSA-757p-vx43-fp9r lists affected ranges: Go github.com/KubeOperator/kubepi >=0 <1.6.5) Commands are suggestions: review each one before running it.
Loading voting…