Privilege escalation (PR)/remote code execution from account through Menu.UIExtensionSheet
CVE-2023-37909GHSA-v2rr-xw95-wcjx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.xwiki.platform:xwiki-platform-menu-ui 15.3-rc-1, 14.10.8; org.xwiki.platform:xwiki-platform-menu 14.10.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.xwiki.platform:xwiki-platform-menu-ui
- Affected
- >= 5.1-rc-1, < 14.10.8>= 15.0-rc-1, < 15.3-rc-1
- Fixed in
- 14.10.8, 15.3-rc-1
Maven org.xwiki.platform:xwiki-platform-menu
- Affected
- >= 5.1-rc-1, < 14.10.8
- Fixed in
- 14.10.8
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v2rr-xw95-wcjx lists affected ranges: Maven org.xwiki.platform:xwiki-platform-menu >=5.1-rc-1 =5.1-rc-1 =15.0-rc-1 <15.3-rc-1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2023-37909: 1.89% estimated exploitation activity in the next 30 days; percentile 79.54 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Any user who can edit their own user profile can execute arbitrary script macros including Groovy and Python macros that allow remote code execution including unrestricted read and write access to all wiki contents. This can be reproduced with the following steps: 1. As an advanced user, use the object editor to add an object of type UIExtensionClass to your user profile. Set the value "Extension Point ID" to {{/html}}{{async async=false cache=false}}{{groovy}}println("Hello from Groovy!"){{/groovy}}{{/async}} 2. Open <xwiki-host/xwiki/bin/edit/XWiki/<username?sheet=Menu.UIExtensionSheet where <xwiki-host is the URL of your XWiki installation and <username is your user name. If the text Hello from Groovy!" selected="selected" is displayed in the output, the attack succeeded. Patches This has been patched in XWiki 14.10.8 and 15.3 RC1 by adding proper escaping. Workarounds The patch can be manually applied to the document Menu.UIExtensionSheet, only three lines need to be…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-v2rr-xw95-wcjx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-37909 Advisory: Privilege escalation (PR)/remote code execution from account through Menu.UIExtensionSheet IDs: CVE-2023-37909, GHSA-v2rr-xw95-wcjx Record: https://patchnext.com/advisories/cve-2023-37909 (revision 1, source checked 26 Oct 2026, 16:17 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.xwiki.platform:xwiki-platform-menu-ui 15.3-rc-1, 14.10.8; org.xwiki.platform:xwiki-platform-menu 14.10.8. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.xwiki.platform:xwiki-platform-menu-ui: affected >= 5.1-rc-1, < 14.10.8; >= 15.0-rc-1, < 15.3-rc-1; fixed in 14.10.8, 15.3-rc-1 - Maven org.xwiki.platform:xwiki-platform-menu: affected >= 5.1-rc-1, < 14.10.8; fixed in 14.10.8 ## Suggested inspection (read-only) - Maven org.xwiki.platform:xwiki-platform-menu-ui: check the installed version with your package manager. - Maven org.xwiki.platform:xwiki-platform-menu: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.xwiki.platform:xwiki-platform-menu-ui, org.xwiki.platform:xwiki-platform-menu. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-v2rr-xw95-wcjx (GitHub-reviewed advisory GHSA-v2rr-xw95-wcjx lists affected ranges: Maven org.xwiki.platform:xwiki-platform-menu >=5.1-rc-1 =5.1-rc-1 =15.0-rc-1 <15.3-rc-1) Commands are suggestions: review each one before running it.
Loading voting…