Indico vulnerable to Cross-Site-Scripting via confirmation prompts
CVE-2023-37901GHSA-fmqq-25x9-c6hm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (indico 3.2.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI indico
- Affected
- < 3.2.6
- Fixed in
- 3.2.6
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-fmqq-25x9-c6hm lists affected ranges: PyPI indico >=0 <3.2.6 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fmqq-25x9-c6hm lists affected ranges: PyPI indico >=0 <3.2.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2023-37901: 0.52% estimated exploitation activity in the next 30 days; percentile 44.01 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact There is a Cross-Site-Scripting vulnerability in confirmation prompts commonly used when deleting content from Indico. Exploitation requires someone with at least submission privileges (such as a speaker) and then someone else to attempt to delete this content. Considering that event organizers may want to delete suspicious-looking content when spotting it, there is a non-negligible risk of such an attack to succeed. The risk of this could be further increased when combined with some some social engineering pointing the victim towards this content. Patches You need to update to Indico 3.2.6 as soon as possible. See the docs for instructions on how to update. Workarounds Only let trustworthy users manage categories, create events or upload materials ("submission" privileges on a contribution/event). This should already be the case in a properly-configured setup when it comes to category/event management. Note that a conference doing a Call for Abstracts actively invites…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-fmqq-25x9-c6hm
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-fmqq-25x9-c6hm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-37901 Advisory: Indico vulnerable to Cross-Site-Scripting via confirmation prompts IDs: CVE-2023-37901, GHSA-fmqq-25x9-c6hm Record: https://patchnext.com/advisories/cve-2023-37901 (revision 3, source checked 26 Oct 2026, 13:17 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: indico 3.2.6. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI indico: affected < 3.2.6; fixed in 3.2.6 ## Suggested inspection (read-only) - `python -m pip show indico`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on indico. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-fmqq-25x9-c6hm (OSV record GHSA-fmqq-25x9-c6hm lists affected ranges: PyPI indico >=0 <3.2.6 (fixed)) - Verified: https://github.com/advisories/GHSA-fmqq-25x9-c6hm (GitHub-reviewed advisory GHSA-fmqq-25x9-c6hm lists affected ranges: PyPI indico >=0 <3.2.6) Commands are suggestions: review each one before running it.
Loading voting…