Skip to content

← Actionable
Low, CVSS 3.4

Denial of service from large image

CVE-2023-37900GHSA-68p4-95xf-7gx8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/crossplane/crossplane 1.12.3, 1.11.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.4 · CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:N/I:N/A:L
EPSS
  • CVE-2023-37900: 0.62% estimated exploitation activity in the next 30 days; percentile 49.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact An high-privileged user could create a Package referencing an arbitrarily large image containing that Crossplane would then parse, possibly resulting in exhausting all the available memory and therefore in the container being OOMKilled. The impact is low due to the high privileges required to be able to create the Package and the eventually consistency nature of controller. Patches The problem has been fixed in 1.11.5, 1.12.3 and 1.13.0, all the supported versions of Crossplane at the time of writing. Workarounds Only using images from trusted sources and keeping Package editing/creating privileges to administrators only, which should be both considered already best practices. References See ADA-XP-23-16 in the Security Audit's report. Credits This was reported as ADA-XP-23-16 by @AdamKorcz and @DavidKorczynski from Ada Logic and facilitated by OSTIF as part of the Security Audit sponsored by CNCF.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-68p4-95xf-7gx8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-37900

Advisory: Denial of service from large image
IDs: CVE-2023-37900, GHSA-68p4-95xf-7gx8
Record: https://patchnext.com/advisories/cve-2023-37900 (revision 1, source checked 26 Oct 2026, 14:59 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/crossplane/crossplane 1.12.3, 1.11.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/crossplane/crossplane: affected < 1.11.5; >= 1.12.0, < 1.12.3; fixed in 1.12.3, 1.11.5

## Suggested inspection (read-only)
- Go github.com/crossplane/crossplane: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/crossplane/crossplane.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-68p4-95xf-7gx8 (GitHub-reviewed advisory GHSA-68p4-95xf-7gx8 lists affected ranges: Go github.com/crossplane/crossplane >=0 =1.12.0 <1.12.3)

Commands are suggestions: review each one before running it.

Loading voting…