Feathers socket handler allows abusing implicit toString
CVE-2023-37899GHSA-hhr9-rh25-hvf9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@feathersjs/socketio 5.0.8, 4.5.18; @feathersjs/transport-commons 5.0.8, 4.5.18), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- <= 4.5.17>= 5.0.0, <= 5.0.7
- Fixed in
- 5.0.8, 4.5.18
npm @feathersjs/transport-commons
- Affected
- <= 4.5.17>= 5.0.0, <= 5.0.7
- Fixed in
- 5.0.8, 4.5.18
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-hhr9-rh25-hvf9 lists affected ranges: npm @feathersjs/socketio >=0 =5.0.0 =0 =5.0.0 <5.0.8 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hhr9-rh25-hvf9 lists affected ranges: npm @feathersjs/socketio >=0 =5.0.0 =0 =5.0.0 <=5.0.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2023-37899: 1.19% estimated exploitation activity in the next 30 days; percentile 67.94 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Feathers socket handler did not catch invalid string conversion errors like: Causing the NodeJS process to crash when sending an unexpected Socket.io message like Patches A fix has been released in - v5.0.8 via #3241 - v4.5.18 via #3242 Workarounds Since it is in the core Socket handling code upgrading to the latest version is necessary. References - v5.0.8 Changelog - v4.5.18 Changelog
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-hhr9-rh25-hvf9
- Revision 1 · created ·
Published from osv record GHSA-hhr9-rh25-hvf9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-37899 Advisory: Feathers socket handler allows abusing implicit toString IDs: CVE-2023-37899, GHSA-hhr9-rh25-hvf9 Record: https://patchnext.com/advisories/cve-2023-37899 (revision 2, source checked 26 Oct 2026, 12:27 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @feathersjs/socketio 5.0.8, 4.5.18; @feathersjs/transport-commons 5.0.8, 4.5.18. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @feathersjs/socketio: affected <= 4.5.17; >= 5.0.0, <= 5.0.7; fixed in 5.0.8, 4.5.18 - npm @feathersjs/transport-commons: affected <= 4.5.17; >= 5.0.0, <= 5.0.7; fixed in 5.0.8, 4.5.18 ## Suggested inspection (read-only) - `npm ls @feathersjs/socketio --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @feathersjs/transport-commons --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @feathersjs/socketio, @feathersjs/transport-commons. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-hhr9-rh25-hvf9 (OSV record GHSA-hhr9-rh25-hvf9 lists affected ranges: npm @feathersjs/socketio >=0 =5.0.0 =0 =5.0.0 <5.0.8 (fixed)) - Verified: https://github.com/advisories/GHSA-hhr9-rh25-hvf9 (GitHub-reviewed advisory GHSA-hhr9-rh25-hvf9 lists affected ranges: npm @feathersjs/socketio >=0 =5.0.0 =0 =5.0.0 <=5.0.7) Commands are suggestions: review each one before running it.
Loading voting…