goproxy Denial of Service vulnerability
CVE-2023-37788GHSA-4r8x-2p26-976p
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/elazarl/goproxy 0.0.0-20230731152917-f99041a5c027), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 0.0.0-20230731152917-f99041a5c027
- Fixed in
- 0.0.0-20230731152917-f99041a5c027
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4r8x-2p26-976p lists affected ranges: Go github.com/elazarl/goproxy >=0 <0.0.0-20230731152917-f99041a5c027
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2023-37788: 0.98% estimated exploitation activity in the next 30 days; percentile 62.25 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
goproxy prior to pseudoversion 0.0.0-20230731152917-f99041a5c027 was discovered to contain an issue which can lead to a Denial of service (DoS) via unspecified vectors.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-4r8x-2p26-976p
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-37788 Advisory: goproxy Denial of Service vulnerability IDs: CVE-2023-37788, GHSA-4r8x-2p26-976p Record: https://patchnext.com/advisories/cve-2023-37788 (revision 1, source checked 26 Oct 2026, 15:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/elazarl/goproxy 0.0.0-20230731152917-f99041a5c027. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/elazarl/goproxy: affected < 0.0.0-20230731152917-f99041a5c027; fixed in 0.0.0-20230731152917-f99041a5c027 ## Suggested inspection (read-only) - Go github.com/elazarl/goproxy: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/elazarl/goproxy. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-4r8x-2p26-976p (GitHub-reviewed advisory GHSA-4r8x-2p26-976p lists affected ranges: Go github.com/elazarl/goproxy >=0 <0.0.0-20230731152917-f99041a5c027) Commands are suggestions: review each one before running it.
Loading voting…