Skip to content

← Actionable
High, CVSS 7.5

Apache Pulsar WebSocket Proxy contains an Improper Authentication vulnerability

CVE-2023-37544GHSA-83q5-whqp-r8jr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.pulsar:pulsar-websocket 3.0.1, 2.11.2, 2.10.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2023-37544: 1.35% estimated exploitation activity in the next 30 days; percentile 71.54 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Improper Authentication vulnerability in Apache Pulsar WebSocket Proxy allows an attacker to connect to the /pingpong endpoint without authentication. This issue affects Apache Pulsar WebSocket Proxy: from 2.8.0 through 2.8., from 2.9.0 through 2.9., from 2.10.0 through 2.10.4, from 2.11.0 through 2.11.1, 3.0.0. The known risks include a denial of service due to the WebSocket Proxy accepting any connections, and excessive data transfer due to misuse of the WebSocket ping/pong feature. 2.10 Pulsar WebSocket Proxy users should upgrade to at least 2.10.5. 2.11 Pulsar WebSocket Proxy users should upgrade to at least 2.11.2. 3.0 Pulsar WebSocket Proxy users should upgrade to at least 3.0.1. 3.1 Pulsar WebSocket Proxy users are unaffected. Any users running the Pulsar WebSocket Proxy for 2.8, 2.9, and earlier should upgrade to one of the above patched versions.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-83q5-whqp-r8jr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-37544

Advisory: Apache Pulsar WebSocket Proxy contains an Improper Authentication vulnerability
IDs: CVE-2023-37544, GHSA-83q5-whqp-r8jr
Record: https://patchnext.com/advisories/cve-2023-37544 (revision 1, source checked 26 Oct 2026, 16:21 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.pulsar:pulsar-websocket 3.0.1, 2.11.2, 2.10.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.pulsar:pulsar-websocket: affected < 2.10.5; >= 2.11.0, < 2.11.2; >= 3.0.0, < 3.0.1; fixed in 3.0.1, 2.11.2, 2.10.5

## Suggested inspection (read-only)
- Maven org.apache.pulsar:pulsar-websocket: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.pulsar:pulsar-websocket.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-83q5-whqp-r8jr (GitHub-reviewed advisory GHSA-83q5-whqp-r8jr lists affected ranges: Maven org.apache.pulsar:pulsar-websocket >=0 =2.11.0 =3.0.0 <3.0.1)

Commands are suggestions: review each one before running it.

Loading voting…