Skip to content

← Actionable
Low, CVSS 2.7amended

Fides Webserver Vulnerable to SVG Bomb File Uploads

CVE-2023-37481GHSA-3rw2-wfc8-wmj5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ethyca-fides 2.16.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
2.7 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:L
EPSS
  • CVE-2023-37481: 0.70% estimated exploitation activity in the next 30 days; percentile 53.37 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The Fides webserver is vulnerable to a type of Denial of Service (DoS) attack. Attackers can exploit this vulnerability to upload zip files containing malicious SVG bombs (similar to a billion laughs attack), causing resource exhaustion in Admin UI browser tabs and creating a persistent denial of service of the 'new connector' page (datastore-connection/new). This vulnerability affects Fides versions 2.11.0 through 2.15.1. Exploitation is limited to users with elevated privileges with the CONNECTORTEMPLATEREGISTER scope, which includes root users and users with the owner role. Patches The vulnerability has been patched in Fides version 2.16.0. Users are advised to upgrade to this version or later to secure their systems against this threat. Workarounds There is no known workaround to remediate this vulnerability without upgrading.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-3rw2-wfc8-wmj5

  2. Revision 1 · created ·

    Published from osv record GHSA-3rw2-wfc8-wmj5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-37481

Advisory: Fides Webserver Vulnerable to SVG Bomb File Uploads
IDs: CVE-2023-37481, GHSA-3rw2-wfc8-wmj5
Record: https://patchnext.com/advisories/cve-2023-37481 (revision 2, source checked 26 Oct 2026, 13:12 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ethyca-fides 2.16.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI ethyca-fides: affected >= 2.11.0, < 2.16.0; fixed in 2.16.0

## Suggested inspection (read-only)
- `python -m pip show ethyca-fides`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ethyca-fides.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-3rw2-wfc8-wmj5 (OSV record GHSA-3rw2-wfc8-wmj5 lists affected ranges: PyPI ethyca-fides >=2.11.0 <2.16.0 (fixed))
- Verified: https://github.com/advisories/GHSA-3rw2-wfc8-wmj5 (GitHub-reviewed advisory GHSA-3rw2-wfc8-wmj5 lists affected ranges: PyPI ethyca-fides >=2.11.0 <2.16.0)

Commands are suggestions: review each one before running it.

Loading voting…