1Panel command injection vulnerability in Firewall ip functionality
CVE-2023-37477GHSA-p9xf-74xh-mhw5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/1Panel-dev/1Panel 1.4.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/1Panel-dev/1Panel
- Affected
- <= 1.4.2
- Fixed in
- 1.4.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-p9xf-74xh-mhw5 lists affected ranges: Go github.com/1Panel-dev/1Panel >=0 <=1.4.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2023-37477: 5.85% estimated exploitation activity in the next 30 days; percentile 93.19 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary An OS command injection vulnerability exists in 1Panel firewall functionality. A specially-crafted HTTP request can lead to arbitrary command execution. An attacker can make an authenticated HTTP request to trigger this vulnerability. Details 1Panel firewall functionality /hosts/firewall/ip endpoint read user input without validation, the attacker extends the default functionality of the application, which execute system commands. PoC the payload ; sleep 3
will lead server response in 3 seconds the payload ; sleep 6
will lead server response in 6 seconds Impact An attacker can execute arbitrary code on the target system, which can lead to a complete compromise of the system. Patches The vulnerability has been fixed in v1.4.3. Workarounds It is recommended to upgrade the version to v1.4.3. References If you have any questions or comments about this advisory: Open an issue in https://github.com/1Panel-dev/1Panel Email us at wanghe@fit2cloud.com
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-p9xf-74xh-mhw5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-37477 Advisory: 1Panel command injection vulnerability in Firewall ip functionality IDs: CVE-2023-37477, GHSA-p9xf-74xh-mhw5 Record: https://patchnext.com/advisories/cve-2023-37477 (revision 1, source checked 26 Oct 2026, 14:59 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/1Panel-dev/1Panel 1.4.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/1Panel-dev/1Panel: affected <= 1.4.2; fixed in 1.4.3 ## Suggested inspection (read-only) - Go github.com/1Panel-dev/1Panel: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/1Panel-dev/1Panel. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-p9xf-74xh-mhw5 (GitHub-reviewed advisory GHSA-p9xf-74xh-mhw5 lists affected ranges: Go github.com/1Panel-dev/1Panel >=0 <=1.4.2) Commands are suggestions: review each one before running it.
Loading voting…