avro vulnerable to denial of service via attacker-controlled parameter
CVE-2023-37475GHSA-9x44-9pgq-cf45
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/hamba/avro/v2 2.13.0; github.com/hamba/avro 2.13.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 2.13.0
- Fixed in
- 2.13.0
- Affected
- < 2.13.0
- Fixed in
- 2.13.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9x44-9pgq-cf45 lists affected ranges: Go github.com/hamba/avro >=0 =0 <2.13.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2023-37475: 0.95% estimated exploitation activity in the next 30 days; percentile 61.38 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A well-crafted string passed to avro's github.com/hamba/avro/v2.Unmarshal() can throw a fatal error: runtime: out of memory which is unrecoverable and can cause denial of service of the consumer of avro. Details The root cause of the issue is that avro uses part of the input to Unmarshal() to determine the size when creating a new slice. In the reproducer below, the first few bytes determine the size of the slice. The root cause is on line 239 here: https://github.com/hamba/avro/blob/3abfe1e6382c5dccf2e1a00260c51a64bc1f1ca1/reader.go#L216-L242 PoC The issue was found during a security audit of Dapr, and I attach a reproducer that shows how the issue affects Dapr. Dapr uses an older version of the avro library, but it is also affected if bumping avro to latest. To reproduce: now add this test to the pulsartest.go: run the test with go test -run=TestParsePublishMetadata2. You should see this stacktrace: Impact Any use case of the avro Unmarshalling routine that accepts…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-9x44-9pgq-cf45
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-37475 Advisory: avro vulnerable to denial of service via attacker-controlled parameter IDs: CVE-2023-37475, GHSA-9x44-9pgq-cf45 Record: https://patchnext.com/advisories/cve-2023-37475 (revision 1, source checked 26 Oct 2026, 14:59 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/hamba/avro/v2 2.13.0; github.com/hamba/avro 2.13.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/hamba/avro/v2: affected < 2.13.0; fixed in 2.13.0 - Go github.com/hamba/avro: affected < 2.13.0; fixed in 2.13.0 ## Suggested inspection (read-only) - Go github.com/hamba/avro/v2: check the installed version with your package manager. - Go github.com/hamba/avro: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/hamba/avro/v2, github.com/hamba/avro. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-9x44-9pgq-cf45 (GitHub-reviewed advisory GHSA-9x44-9pgq-cf45 lists affected ranges: Go github.com/hamba/avro >=0 =0 <2.13.0) Commands are suggestions: review each one before running it.
Loading voting…