vm2 Sandbox Escape vulnerability
CVE-2023-37466GHSA-cchq-frgv-rjh5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (vm2 3.10.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm vm2
- Affected
- <= 3.9.19
- Fixed in
- 3.10.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-cchq-frgv-rjh5 lists affected ranges: npm vm2 >=0 <3.10.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cchq-frgv-rjh5 lists affected ranges: npm vm2 >=0 <=3.9.19
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2023-37466: 3.87% estimated exploitation activity in the next 30 days; percentile 90.20 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In vm2 for versions up to 3.9.19, Promise handler sanitization can be bypassed, allowing attackers to escape the sandbox and run arbitrary code. Impact Remote Code Execution, assuming the attacker has arbitrary code execution primitive inside the context of vm2 sandbox. Patches None. Workarounds None. References PoC - https://gist.github.com/leesh3288/f693061e6523c97274ad5298eb2c74e9 For more information If you have any questions or comments about this advisory: - Open an issue in VM2 Thanks to Xion (SeungHyun Lee) of KAIST Hacking Lab for disclosing this vulnerability.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-cchq-frgv-rjh5
- Revision 1 · created ·
Published from osv record GHSA-cchq-frgv-rjh5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-37466 Advisory: vm2 Sandbox Escape vulnerability IDs: CVE-2023-37466, GHSA-cchq-frgv-rjh5 Record: https://patchnext.com/advisories/cve-2023-37466 (revision 2, source checked 26 Oct 2026, 12:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: vm2 3.10.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm vm2: affected <= 3.9.19; fixed in 3.10.0 ## Suggested inspection (read-only) - `npm ls vm2 --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on vm2. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-cchq-frgv-rjh5 (OSV record GHSA-cchq-frgv-rjh5 lists affected ranges: npm vm2 >=0 <3.10.0 (fixed)) - Verified: https://github.com/advisories/GHSA-cchq-frgv-rjh5 (GitHub-reviewed advisory GHSA-cchq-frgv-rjh5 lists affected ranges: npm vm2 >=0 <=3.9.19) Commands are suggestions: review each one before running it.
Loading voting…