Skip to content

← Actionable
High, CVSS 7.2amended

Apache Airflow denial of service vulnerability

CVE-2023-37379GHSA-x2mh-8fmc-rqgh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (apache-airflow 2.7.0b1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.2 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2023-37379: 1.96% estimated exploitation activity in the next 30 days; percentile 80.31 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Apache Airflow, in versions prior to 2.7.0, contains a security vulnerability that can be exploited by an authenticated user possessing Connection edit privileges. This vulnerability allows the user to access connection information and exploit the test connection feature by sending many requests, leading to a denial of service (DoS) condition on the server. Furthermore, malicious actors can leverage this vulnerability to establish harmful connections with the server. Users of Apache Airflow are strongly advised to upgrade to version 2.7.0 or newer to mitigate the risk associated with this vulnerability. Additionally, administrators are encouraged to review and adjust user permissions to restrict access to sensitive functionalities, reducing the attack surface.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-x2mh-8fmc-rqgh

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-x2mh-8fmc-rqgh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-37379

Advisory: Apache Airflow denial of service vulnerability
IDs: CVE-2023-37379, GHSA-x2mh-8fmc-rqgh
Record: https://patchnext.com/advisories/cve-2023-37379 (revision 3, source checked 26 Oct 2026, 13:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: apache-airflow 2.7.0b1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI apache-airflow: affected < 2.7.0b1; fixed in 2.7.0b1

## Suggested inspection (read-only)
- `python -m pip show apache-airflow`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on apache-airflow.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-x2mh-8fmc-rqgh (OSV record GHSA-x2mh-8fmc-rqgh lists affected ranges: PyPI apache-airflow >=0 <2.7.0b1 (fixed))
- Verified: https://github.com/advisories/GHSA-x2mh-8fmc-rqgh (GitHub-reviewed advisory GHSA-x2mh-8fmc-rqgh lists affected ranges: PyPI apache-airflow >=0 <2.7.0b1)

Commands are suggestions: review each one before running it.

Loading voting…