Skip to content

← Actionable
Critical, CVSS 9.6

XWiki Platform vulnerable to cross-site request forgery (CSRF) via the REST API

CVE-2023-37277GHSA-6xxr-648m-gch6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.xwiki.platform:xwiki-platform-rest-server 15.2, 14.10.8; com.xpn.xwiki.platform:xwiki-rest 14.10.8; com.xpn.xwiki.platform:xwiki-core-rest-server 14.10.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-6xxr-648m-gch6 lists affected ranges: Maven org.xwiki.platform:xwiki-platform-rest-server >=1.8 =15.0-rc-1 =1.8 =1.8 <14.10.8

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
EPSS
  • CVE-2023-37277: 0.67% estimated exploitation activity in the next 30 days; percentile 51.99 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The REST API allows executing all actions via POST requests and accepts text/plain, multipart/form-data or application/www-form-urlencoded as content types which can be sent via regular HTML forms, thus allowing cross-site request forgery. With the interaction of a user with programming rights, this allows remote code execution through script macros and thus impacts the integrity, availability and confidentiality of the whole XWiki installation. For regular cookie-based authentication, the vulnerability is mitigated by SameSite cookie restrictions but as of March 2023, these are not enabled by default in Firefox and Safari. Patches The vulnerability has been patched in XWiki 14.10.8 and 15.2 by requiring a CSRF token header for certain request types that are susceptible to CSRF attacks. Workarounds It is possible to check for the Origin header in a reverse proxy to protect the REST endpoint from CSRF attacks, see the Jira issue for an example configuration. References…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-6xxr-648m-gch6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-37277

Advisory: XWiki Platform vulnerable to cross-site request forgery (CSRF) via the REST API
IDs: CVE-2023-37277, GHSA-6xxr-648m-gch6
Record: https://patchnext.com/advisories/cve-2023-37277 (revision 1, source checked 26 Oct 2026, 16:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.xwiki.platform:xwiki-platform-rest-server 15.2, 14.10.8; com.xpn.xwiki.platform:xwiki-rest 14.10.8; com.xpn.xwiki.platform:xwiki-core-rest-server 14.10.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.xwiki.platform:xwiki-platform-rest-server: affected >= 1.8, < 14.10.8; >= 15.0-rc-1, < 15.2; fixed in 14.10.8, 15.2
- Maven com.xpn.xwiki.platform:xwiki-rest: affected >= 1.8, < 14.10.8; fixed in 14.10.8
- Maven com.xpn.xwiki.platform:xwiki-core-rest-server: affected >= 1.8, < 14.10.8; fixed in 14.10.8

## Suggested inspection (read-only)
- Maven org.xwiki.platform:xwiki-platform-rest-server: check the installed version with your package manager.
- Maven com.xpn.xwiki.platform:xwiki-rest: check the installed version with your package manager.
- Maven com.xpn.xwiki.platform:xwiki-core-rest-server: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.xwiki.platform:xwiki-platform-rest-server, com.xpn.xwiki.platform:xwiki-rest, com.xpn.xwiki.platform:xwiki-core-rest-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-6xxr-648m-gch6 (GitHub-reviewed advisory GHSA-6xxr-648m-gch6 lists affected ranges: Maven org.xwiki.platform:xwiki-platform-rest-server >=1.8 =15.0-rc-1 =1.8 =1.8 <14.10.8)

Commands are suggestions: review each one before running it.

Loading voting…