Skip to content

← Actionable
Medium, CVSS 6.9amended

aiohttp.web.Application vulnerable to HTTP request smuggling via llhttp HTTP request parser

CVE-2023-37276GHSA-45c4-8wx5-qw6w

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (aiohttp 3.8.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI aiohttp

    Affected
    <= 3.8.4
    Fixed in
    3.8.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2023-37276: 1.34% estimated exploitation activity in the next 30 days; percentile 71.26 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact aiohttp v3.8.4 and earlier are bundled with llhttp v6.0.6 which is vulnerable to CVE-2023-30589. The vulnerable code is used by aiohttp for its HTTP request parser when available which is the default case when installing from a wheel. This vulnerability only affects users of aiohttp as an HTTP server (ie aiohttp.Application), you are not affected by this vulnerability if you are using aiohttp as an HTTP client library (ie aiohttp.ClientSession). Reproducer Sending a crafted HTTP request will cause the server to misinterpret one of the HTTP header values leading to HTTP request smuggling. Patches Upgrade to the latest version of aiohttp to resolve this vulnerability. It has been fixed in v3.8.5: pip install aiohttp = 3.8.5 Workarounds If you aren't able to upgrade you can reinstall aiohttp using AIOHTTPNOEXTENSIONS=1 as an environment variable to disable the llhttp HTTP request parser implementation. The pure Python implementation isn't vulnerable to request smuggling:…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-45c4-8wx5-qw6w

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-45c4-8wx5-qw6w

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-37276

Advisory: aiohttp.web.Application vulnerable to HTTP request smuggling via llhttp HTTP request parser
IDs: CVE-2023-37276, GHSA-45c4-8wx5-qw6w
Record: https://patchnext.com/advisories/cve-2023-37276 (revision 3, source checked 26 Oct 2026, 13:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: aiohttp 3.8.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI aiohttp: affected <= 3.8.4; fixed in 3.8.5

## Suggested inspection (read-only)
- `python -m pip show aiohttp`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on aiohttp.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-45c4-8wx5-qw6w (OSV record GHSA-45c4-8wx5-qw6w lists affected ranges: PyPI aiohttp >=0 <3.8.5 (fixed))
- Verified: https://github.com/advisories/GHSA-45c4-8wx5-qw6w (GitHub-reviewed advisory GHSA-45c4-8wx5-qw6w lists affected ranges: PyPI aiohttp >=0 <=3.8.4)

Commands are suggestions: review each one before running it.

Loading voting…