Skip to content

← Actionable
High, CVSS 8.4amended

RestrictedPython vulnerable to arbitrary code execution via stack frame sandbox escape

CVE-2023-37271GHSA-wqc8-x2pr-7jqh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (restrictedpython 6.1, 5.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.4 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:L
EPSS
  • CVE-2023-37271: 0.85% estimated exploitation activity in the next 30 days; percentile 58.14 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact RestrictedPython does not check access to stack frames and their attributes. Stack frames are accessible within at least generators and generator expressions, which are allowed inside RestrictedPython. An attacker with access to a RestrictedPython environment can write code that gets the current stack frame in a generator and then walk the stack all the way beyond the RestrictedPython invocation boundary, thus breaking out of the restricted scope allowing the call of unrestricted Python code and therefore potentially allowing arbitrary code execution in the Python interpreter. All RestrictedPython deployments that allow untrusted users to write Python code in the RestrictedPython environment are at risk. In terms of Zope and Plone, this would mean deployments where the administrator allows untrusted users to create and/or edit objects of type Script (Python), DTML Method, DTML Document or Zope Page Template. This is a non-default configuration and likely to be extremely rare.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-wqc8-x2pr-7jqh

  2. Revision 1 · created ·

    Published from osv record GHSA-wqc8-x2pr-7jqh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-37271

Advisory: RestrictedPython vulnerable to arbitrary code execution via stack frame sandbox escape
IDs: CVE-2023-37271, GHSA-wqc8-x2pr-7jqh
Record: https://patchnext.com/advisories/cve-2023-37271 (revision 2, source checked 26 Oct 2026, 13:12 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: restrictedpython 6.1, 5.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI restrictedpython: affected < 5.3; >= 6.0a1.dev0, < 6.1; < 5.3; fixed in 6.1, 5.3

## Suggested inspection (read-only)
- `python -m pip show restrictedpython`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on restrictedpython.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-wqc8-x2pr-7jqh (OSV record GHSA-wqc8-x2pr-7jqh lists affected ranges: PyPI restrictedpython >=0 =6.0a1.dev0 <6.1 (fixed))
- Verified: https://github.com/advisories/GHSA-wqc8-x2pr-7jqh (GitHub-reviewed advisory GHSA-wqc8-x2pr-7jqh lists affected ranges: PyPI restrictedpython >=0 =6.0a1.dev0 =0 <5.3)

Commands are suggestions: review each one before running it.

Loading voting…