Skip to content

← Actionable
Medium, CVSS 6.8amended

Strapi's field level permissions not being respected in relationship title

CVE-2023-37263GHSA-m284-85mf-cgrc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@strapi/plugin-content-manager 4.12.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:N/A:N
EPSS
  • CVE-2023-37263: 0.64% estimated exploitation activity in the next 30 days; percentile 50.47 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Field level permissions not being respected in relationship title. If I have a relationship title and the relationship shows a field I don't have permission to see I will still be visible. Details No RBAC checks on on the relationship the relation endpoint returns PoC Setup Create a fresh strapi instance Create a new content type in the newly created content type add a relation to the users-permissions user. Save. Create a users-permissions user Use your created content type and create an entry in it related to the users-permisisons user Go to settings - Admin panel - Roles - Author Give the author role full permissions on the content type your created. Make sure they don't have any permission to see User Save Create a new admin account with only the author role CVE login on the newly created author acount. go to the content manager to the colection type you created with the relationship to userspermissionsuser You now see a field you don't have permissions to view. Impact…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-m284-85mf-cgrc

  2. Revision 1 · created ·

    Published from osv record GHSA-m284-85mf-cgrc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-37263

Advisory: Strapi's field level permissions not being respected in relationship title
IDs: CVE-2023-37263, GHSA-m284-85mf-cgrc
Record: https://patchnext.com/advisories/cve-2023-37263 (revision 2, source checked 26 Oct 2026, 12:31 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @strapi/plugin-content-manager 4.12.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @strapi/plugin-content-manager: affected < 4.12.1; fixed in 4.12.1

## Suggested inspection (read-only)
- `npm ls @strapi/plugin-content-manager --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @strapi/plugin-content-manager.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-m284-85mf-cgrc (OSV record GHSA-m284-85mf-cgrc lists affected ranges: npm @strapi/plugin-content-manager >=0 <4.12.1 (fixed))
- Verified: https://github.com/advisories/GHSA-m284-85mf-cgrc (GitHub-reviewed advisory GHSA-m284-85mf-cgrc lists affected ranges: npm @strapi/plugin-content-manager >=0 <4.12.1)

Commands are suggestions: review each one before running it.

Loading voting…