Skip to content

← Actionable
Critical, CVSS 10.0amended

Mongoose Prototype Pollution vulnerability

CVE-2023-3696GHSA-9m93-w8w6-76hh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mongoose 7.3.3, 6.11.3, 5.13.20), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm mongoose

    Affected
    >= 7.0.0, < 7.3.3>= 6.0.0, < 6.11.3< 5.13.20
    Fixed in
    5.13.20, 7.3.3, 6.11.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
10.0 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:H
EPSS
  • CVE-2023-3696: 1.21% estimated exploitation activity in the next 30 days; percentile 68.40 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Prototype Pollution in GitHub repository automattic/mongoose prior to 7.3.3, 6.11.3, and 5.13.20.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-9m93-w8w6-76hh

  2. Revision 1 · created ·

    Published from osv record GHSA-9m93-w8w6-76hh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-3696

Advisory: Mongoose Prototype Pollution vulnerability
IDs: CVE-2023-3696, GHSA-9m93-w8w6-76hh
Record: https://patchnext.com/advisories/cve-2023-3696 (revision 2, source checked 26 Oct 2026, 12:29 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 10.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mongoose 7.3.3, 6.11.3, 5.13.20. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm mongoose: affected >= 7.0.0, < 7.3.3; >= 6.0.0, < 6.11.3; < 5.13.20; fixed in 5.13.20, 7.3.3, 6.11.3

## Suggested inspection (read-only)
- `npm ls mongoose --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mongoose.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-9m93-w8w6-76hh (OSV record GHSA-9m93-w8w6-76hh lists affected ranges: npm mongoose >=7.0.0 =6.0.0 =0 <5.13.20 (fixed))
- Verified: https://github.com/advisories/GHSA-9m93-w8w6-76hh (GitHub-reviewed advisory GHSA-9m93-w8w6-76hh lists affected ranges: npm mongoose >=7.0.0 =6.0.0 =0 <5.13.20)

Commands are suggestions: review each one before running it.

Loading voting…