Sentry CORS misconfiguration
CVE-2023-36829GHSA-4xqm-4p72-87h6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (sentry 23.6.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI sentry
- Affected
- >= 23.6.0, < 23.6.2
- Fixed in
- 23.6.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-4xqm-4p72-87h6 lists affected ranges: PyPI sentry >=23.6.0 <23.6.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4xqm-4p72-87h6 lists affected ranges: PyPI sentry >=23.6.0 <23.6.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.8 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N
- EPSS
- CVE-2023-36829: 0.67% estimated exploitation activity in the next 30 days; percentile 51.87 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The Sentry API incorrectly returns the access-control-allow-credentials: true HTTP header if the Origin request header ends with the system.base-hostname option of Sentry installation. This only affects installations that have system.base-hostname option explicitly set, as it is empty by default. Impact is limited since recent versions of major browsers have cross-site cookie blocking enabled by default. However, this flaw could allow other multi-step attacks. Patches The patch has been released in Sentry 23.6.2. Workarounds For Sentry SaaS customers, no action is needed. For self-hosted Sentry installations that have system.base-hostname explicitly set, it is recommended to upgrade the installation to 23.6.2 or higher. There are no known workarounds. References - getsentry/sentry PR #52276 Credits - @andr0idp4r4n0id
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-4xqm-4p72-87h6
- Revision 1 · created ·
Published from osv record GHSA-4xqm-4p72-87h6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-36829 Advisory: Sentry CORS misconfiguration IDs: CVE-2023-36829, GHSA-4xqm-4p72-87h6 Record: https://patchnext.com/advisories/cve-2023-36829 (revision 2, source checked 26 Oct 2026, 13:12 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: sentry 23.6.2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI sentry: affected >= 23.6.0, < 23.6.2; fixed in 23.6.2 ## Suggested inspection (read-only) - `python -m pip show sentry`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on sentry. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-4xqm-4p72-87h6 (OSV record GHSA-4xqm-4p72-87h6 lists affected ranges: PyPI sentry >=23.6.0 <23.6.2 (fixed)) - Verified: https://github.com/advisories/GHSA-4xqm-4p72-87h6 (GitHub-reviewed advisory GHSA-4xqm-4p72-87h6 lists affected ranges: PyPI sentry >=23.6.0 <23.6.2) Commands are suggestions: review each one before running it.
Loading voting…