Improper authorization on debug and artifact file downloads
CVE-2023-36826GHSA-m4hc-m2v6-hfw8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (sentry 23.5.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI sentry
- Affected
- >= 8.21.0, < 23.5.2
- Fixed in
- 23.5.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-m4hc-m2v6-hfw8 lists affected ranges: PyPI sentry >=8.21.0 <23.5.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-m4hc-m2v6-hfw8 lists affected ranges: PyPI sentry >=8.21.0 <23.5.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N · score source
- EPSS
- CVE-2023-36826: 0.63% estimated exploitation activity in the next 30 days; percentile 50.43 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact An authenticated user can download a debug or artifact bundle from arbitrary organizations and projects with a known bundle ID. The user does not need to be a member of the organization or have permissions on the project. Patches A patch was issued to ensure authorization checks are properly scoped on requests to retrieve debug or artifact bundles. Authenticated users who do not have the necessary permissions on the particular project are no longer able to download them. Sentry SaaS users do not need to take any action. Self-Hosted Sentry users should upgrade to version 23.5.2 or higher. References - Restrict file downloads to Project
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-m4hc-m2v6-hfw8
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-m4hc-m2v6-hfw8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-36826 Advisory: Improper authorization on debug and artifact file downloads IDs: CVE-2023-36826, GHSA-m4hc-m2v6-hfw8 Record: https://patchnext.com/advisories/cve-2023-36826 (revision 3, source checked 26 Oct 2026, 13:25 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: sentry 23.5.2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI sentry: affected >= 8.21.0, < 23.5.2; fixed in 23.5.2 ## Suggested inspection (read-only) - `python -m pip show sentry`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on sentry. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-m4hc-m2v6-hfw8 (OSV record GHSA-m4hc-m2v6-hfw8 lists affected ranges: PyPI sentry >=8.21.0 <23.5.2 (fixed)) - Verified: https://github.com/advisories/GHSA-m4hc-m2v6-hfw8 (GitHub-reviewed advisory GHSA-m4hc-m2v6-hfw8 lists affected ranges: PyPI sentry >=8.21.0 <23.5.2) Commands are suggestions: review each one before running it.
Loading voting…