Orchid Deserialization of Untrusted Data vulnerability leads to Remote Code Execution
CVE-2023-36825GHSA-ph6g-p72v-pc3p
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (orchid/platform 14.5.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist orchid/platform
- Affected
- >= 14.0.0-alpha4, < 14.5.0
- Fixed in
- 14.5.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-ph6g-p72v-pc3p lists affected ranges: Packagist orchid/platform >=14.0.0-alpha4 <14.5.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2023-36825: 1.13% estimated exploitation activity in the next 30 days; percentile 66.32 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Orchid is a Laravel package that allows application development of back-office applications, admin/user panels, and dashboards. Impact A vulnerability present starting in version 14.0.0-alpha4 and prior to version 14.5.0 is related to the deserialization of untrusted data from the state query parameter, which can result in remote code execution. This vulnerability is related to the deserialization of untrusted data from the state query parameter, which can result in remote code execution. Patches The issue has been addressed in version 14.5.0. Users are advised to upgrade their software to this version or any subsequent versions that include the patch. There are no known workarounds. Workarounds In this case, it is recommended for users to upgrade to the patched version rather than relying on workarounds. Upgrading to the fixed version ensures that the vulnerability is no longer present and provides the best protection against remote code execution References For more detailed…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-ph6g-p72v-pc3p
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-36825 Advisory: Orchid Deserialization of Untrusted Data vulnerability leads to Remote Code Execution IDs: CVE-2023-36825, GHSA-ph6g-p72v-pc3p Record: https://patchnext.com/advisories/cve-2023-36825 (revision 1, source checked 26 Oct 2026, 14:10 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: orchid/platform 14.5.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist orchid/platform: affected >= 14.0.0-alpha4, < 14.5.0; fixed in 14.5.0 ## Suggested inspection (read-only) - Packagist orchid/platform: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on orchid/platform. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-ph6g-p72v-pc3p (GitHub-reviewed advisory GHSA-ph6g-p72v-pc3p lists affected ranges: Packagist orchid/platform >=14.0.0-alpha4 <14.5.0) Commands are suggestions: review each one before running it.
Loading voting…