Sanitize vulnerable to Cross-site Scripting via insufficient neutralization of style element content
CVE-2023-36823GHSA-f5ww-cq3m-q3g7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (sanitize 6.0.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems sanitize
- Affected
- >= 3.0.0, < 6.0.2
- Fixed in
- 6.0.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-f5ww-cq3m-q3g7 lists affected ranges: RubyGems sanitize >=3.0.0 <6.0.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L
- EPSS
- CVE-2023-36823: 0.71% estimated exploitation activity in the next 30 days; percentile 53.63 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Using carefully crafted input, an attacker may be able to sneak arbitrary HTML and CSS through Sanitize = 3.0.0, < 6.0.2 when Sanitize is configured to use the built-in "relaxed" config or when using a custom config that allows style elements and one or more CSS at-rules. This could result in XSS (cross-site scripting) or other undesired behavior when the malicious HTML and CSS are rendered in a browser. Patches Sanitize = 6.0.2 performs additional escaping of CSS in style element content, which fixes this issue. Workarounds Users who are unable to upgrade can prevent this issue by using a Sanitize config that doesn't allow style elements, using a Sanitize config that doesn't allow CSS at-rules, or by manually escaping the character sequence </ as <\/ in style element content. Credit This issue was found by @cure53 during an audit of a project that uses Sanitize and was reported by one of that project's maintainers. Thank you!
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-f5ww-cq3m-q3g7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-36823 Advisory: Sanitize vulnerable to Cross-site Scripting via insufficient neutralization of `style` element content IDs: CVE-2023-36823, GHSA-f5ww-cq3m-q3g7 Record: https://patchnext.com/advisories/cve-2023-36823 (revision 1, source checked 26 Oct 2026, 15:48 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: sanitize 6.0.2. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems sanitize: affected >= 3.0.0, < 6.0.2; fixed in 6.0.2 ## Suggested inspection (read-only) - RubyGems sanitize: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on sanitize. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-f5ww-cq3m-q3g7 (GitHub-reviewed advisory GHSA-f5ww-cq3m-q3g7 lists affected ranges: RubyGems sanitize >=3.0.0 <6.0.2) Commands are suggestions: review each one before running it.
Loading voting…