Skip to content

← Actionable
Medium, CVSS 6.5amended

Uptime Kuma's authenticated path traversal via plugin repository name may lead to unavailability or data loss

CVE-2023-36822GHSA-vr8x-74pm-6vj7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (uptime-kuma 1.22.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2023-36822: 1.21% estimated exploitation activity in the next 30 days; percentile 68.55 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A path traversal vulnerability via the plugin repository name allows an authenticated attacker to delete files on the server leading to unavailability and potentially data loss. Details Uptime Kuma allows authenticated users to install plugins from an official list of plugins. This feature is currently disabled in the web interface, but the corresponding API endpoints are still available after login. Before a plugin is downloaded, the plugin installation directory is checked for existence. If it exists, it's removed before the plugin installation. Because the plugin is not validated against the official list of plugins or sanitized, the check for existence and the removal of the plugin installation directory are prone to path traversal. Impact This vulnerability allows an authenticated attacker to delete files from the server Uptime Kuma is running on. Depending on which files are deleted, Uptime Kuma or the whole system may become unavailable due to data loss.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-vr8x-74pm-6vj7

  2. Revision 1 · created ·

    Published from osv record GHSA-vr8x-74pm-6vj7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-36822

Advisory: Uptime Kuma's authenticated path traversal via plugin repository name may lead to unavailability or data loss
IDs: CVE-2023-36822, GHSA-vr8x-74pm-6vj7
Record: https://patchnext.com/advisories/cve-2023-36822 (revision 2, source checked 26 Oct 2026, 12:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: uptime-kuma 1.22.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm uptime-kuma: affected <= 1.22.0; fixed in 1.22.1

## Suggested inspection (read-only)
- `npm ls uptime-kuma --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on uptime-kuma.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-vr8x-74pm-6vj7 (OSV record GHSA-vr8x-74pm-6vj7 lists affected ranges: npm uptime-kuma >=0 <1.22.1 (fixed))
- Verified: https://github.com/advisories/GHSA-vr8x-74pm-6vj7 (GitHub-reviewed advisory GHSA-vr8x-74pm-6vj7 lists affected ranges: npm uptime-kuma >=0 <=1.22.0)

Commands are suggestions: review each one before running it.

Loading voting…