Skip to content

← Actionable
High, CVSS 8.8amended

Uptime Kuma vulnerable to authenticated remote code execution via malicious plugin installation

CVE-2023-36821GHSA-7grx-f945-mj96

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (uptime-kuma 1.22.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2023-36821: 2.02% estimated exploitation activity in the next 30 days; percentile 80.94 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Installation of a maliciously crafted plugin allows for remote code execution by an authenticated attacker. Details Uptime Kuma allows authenticated users to install plugins from an official list of plugins. This feature is currently disabled in the web interface, but the corresponding API endpoints are still available after login. After downloading a plugin, it's installed by calling npm install in the installation directory of the plugin: https://github.com/louislam/uptime-kuma/blob/8c60e902e1c76ecbbd1b0423b07ce615341cb850/server/plugins-manager.js#L210-L216 Because the plugin is not validated against the official list of plugins or installed with npm install --ignore-scripts, a maliciously crafted plugin taking advantage of npm scripts can gain remote code execution. PoC In the PoC below, the plugin at https://github.com/n-thumann/npm-install-script-poc will be installed. It only consists of an empty index.js and a package.json containing the script: "preinstall": "echo…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-7grx-f945-mj96

  2. Revision 1 · created ·

    Published from osv record GHSA-7grx-f945-mj96

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-36821

Advisory: Uptime Kuma vulnerable to authenticated remote code execution via malicious plugin installation
IDs: CVE-2023-36821, GHSA-7grx-f945-mj96
Record: https://patchnext.com/advisories/cve-2023-36821 (revision 2, source checked 26 Oct 2026, 12:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: uptime-kuma 1.22.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm uptime-kuma: affected <= 1.22.0; fixed in 1.22.1

## Suggested inspection (read-only)
- `npm ls uptime-kuma --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on uptime-kuma.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-7grx-f945-mj96 (OSV record GHSA-7grx-f945-mj96 lists affected ranges: npm uptime-kuma >=0 <1.22.1 (fixed))
- Verified: https://github.com/advisories/GHSA-7grx-f945-mj96 (GitHub-reviewed advisory GHSA-7grx-f945-mj96 lists affected ranges: npm uptime-kuma >=0 <=1.22.0)

Commands are suggestions: review each one before running it.

Loading voting…