PyPDF2 vulnerable to possible Infinite Loop when reading malformed objects
CVE-2023-36807GHSA-hm9v-vj3r-r55m
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pypdf2 2.10.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI pypdf2
- Affected
- >= 2.10.5, <= 2.10.5
- Fixed in
- 2.10.6
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-hm9v-vj3r-r55m lists affected ranges: PyPI pypdf2 >=2.10.5 <2.10.6 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hm9v-vj3r-r55m lists affected ranges: PyPI pypdf2 >=2.10.5 <=2.10.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.2 · CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2023-36807: 0.57% estimated exploitation activity in the next 30 days; percentile 47.40 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact An attacker who uses this vulnerability can craft a PDF which leads to an infinite loop. This infinite loop blocks the current process and can utilize a single core of the CPU by 100%. It does not affect memory usage. That is, for example, the case if the user extracted metadata from such a malformed PDF. Patches The issue was fixed with https://github.com/py-pdf/pypdf/pull/1331 Workarounds If you cannot update your version of PyPDF2 (preferably to pypdf3.1.0 as PyPDF2 is deprecated), you should modify PyPDF2/generic/datastructures.py::readobject. Replace: by References pypdf issue #1329 pypdf PR #1331
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-hm9v-vj3r-r55m
- Revision 1 · created ·
Published from osv record GHSA-hm9v-vj3r-r55m
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-36807 Advisory: PyPDF2 vulnerable to possible Infinite Loop when reading malformed objects IDs: CVE-2023-36807, GHSA-hm9v-vj3r-r55m Record: https://patchnext.com/advisories/cve-2023-36807 (revision 2, source checked 26 Oct 2026, 13:12 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pypdf2 2.10.6. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI pypdf2: affected >= 2.10.5, <= 2.10.5; fixed in 2.10.6 ## Suggested inspection (read-only) - `python -m pip show pypdf2`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pypdf2. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-hm9v-vj3r-r55m (OSV record GHSA-hm9v-vj3r-r55m lists affected ranges: PyPI pypdf2 >=2.10.5 <2.10.6 (fixed)) - Verified: https://github.com/advisories/GHSA-hm9v-vj3r-r55m (GitHub-reviewed advisory GHSA-hm9v-vj3r-r55m lists affected ranges: PyPI pypdf2 >=2.10.5 <=2.10.5) Commands are suggestions: review each one before running it.
Loading voting…