Aerospike Java Client vulnerable to unsafe deserialization of server responses
CVE-2023-36480GHSA-jj95-55cr-9597
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.aerospike:aerospike-client 6.2.0, 5.2.0, 4.5.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven com.aerospike:aerospike-client
- Affected
- >= 6.0.0, < 6.2.0>= 5.0.0, < 5.2.0< 4.5.0
- Fixed in
- 4.5.0, 5.2.0, 6.2.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jj95-55cr-9597 lists affected ranges: Maven com.aerospike:aerospike-client >=6.0.0 =5.0.0 =0 <4.5.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2023-36480: 1.78% estimated exploitation activity in the next 30 days; percentile 78.23 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
GitHub Security Lab (GHSL) Vulnerability Report: GHSL-2023-044 The GitHub Security Lab team has identified a potential security vulnerability in Aerospike Java Client. We are committed to working with you to help resolve this issue. In this report you will find everything you need to effectively coordinate a resolution of this issue with the GHSL team. If at any point you have concerns or questions about this process, please do not hesitate to reach out to us at securitylab@github.com (please include GHSL-2023-044 as a reference). If you are NOT the correct point of contact for this report, please let us know! Summary The Aerospike Java client is a Java application that implements a network protocol to communicate with an Aerospike server. Some of the messages received from the server contain Java objects that the client deserializes when it encounters them without further validation. Attackers that manage to trick clients into communicating with a malicious server can include…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-jj95-55cr-9597
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-36480 Advisory: Aerospike Java Client vulnerable to unsafe deserialization of server responses IDs: CVE-2023-36480, GHSA-jj95-55cr-9597 Record: https://patchnext.com/advisories/cve-2023-36480 (revision 1, source checked 26 Oct 2026, 16:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: com.aerospike:aerospike-client 6.2.0, 5.2.0, 4.5.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven com.aerospike:aerospike-client: affected >= 6.0.0, < 6.2.0; >= 5.0.0, < 5.2.0; < 4.5.0; fixed in 4.5.0, 5.2.0, 6.2.0 ## Suggested inspection (read-only) - Maven com.aerospike:aerospike-client: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on com.aerospike:aerospike-client. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-jj95-55cr-9597 (GitHub-reviewed advisory GHSA-jj95-55cr-9597 lists affected ranges: Maven com.aerospike:aerospike-client >=6.0.0 =5.0.0 =0 <4.5.0) Commands are suggestions: review each one before running it.
Loading voting…