Skip to content

← Actionable
Low, CVSS 3.5

Jetty vulnerable to errant command quoting in CGI Servlet

CVE-2023-36479GHSA-3gh6-v5v9-6v9j

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.eclipse.jetty:jetty-servlets 11.0.16, 10.0.16, 9.4.52; org.eclipse.jetty.ee9:jetty-ee9-servlets 12.0.0-beta2; org.eclipse.jetty.ee8:jetty-ee8-servlets 12.0.0-beta2; org.eclipse.jetty.ee10:jetty-ee10-servlets 12.0.0-beta2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-3gh6-v5v9-6v9j lists affected ranges: Maven org.eclipse.jetty:jetty-servlets >=9.0.0 =10.0.0 =11.0.0 =0 =0 =0 <=12.0.0-beta1

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.5 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:N/I:L/A:N
EPSS
  • CVE-2023-36479: 1.16% estimated exploitation activity in the next 30 days; percentile 67.24 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

If a user sends a request to a org.eclipse.jetty.servlets.CGI Servlet for a binary with a space in its name, the servlet will escape the command by wrapping it in quotation marks. This wrapped command, plus an optional command prefix, will then be executed through a call to Runtime.exec. If the original binary name provided by the user contains a quotation mark followed by a space, the resulting command line will contain multiple tokens instead of one. For example, if a request references a binary called file” name “here, the escaping algorithm will generate the command line string “file” name “here”, which will invoke the binary named file, not the one that the user requested. Exploit Scenario The cgi-bin directory contains a binary named exec and a subdirectory named exec” commands, which contains a file called bin1. The user sends to the CGI servlet a request for the filename exec” commands/bin1. This request will pass the file existence check on lines 194 through 205. The servlet…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-3gh6-v5v9-6v9j

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-36479

Advisory: Jetty vulnerable to errant command quoting in CGI Servlet
IDs: CVE-2023-36479, GHSA-3gh6-v5v9-6v9j
Record: https://patchnext.com/advisories/cve-2023-36479 (revision 1, source checked 26 Oct 2026, 16:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.eclipse.jetty:jetty-servlets 11.0.16, 10.0.16, 9.4.52; org.eclipse.jetty.ee9:jetty-ee9-servlets 12.0.0-beta2; org.eclipse.jetty.ee8:jetty-ee8-servlets 12.0.0-beta2; org.eclipse.jetty.ee10:jetty-ee10-servlets 12.0.0-beta2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.eclipse.jetty:jetty-servlets: affected >= 9.0.0, <= 9.4.51; >= 10.0.0, <= 10.0.15; >= 11.0.0, <= 11.0.15; fixed in 9.4.52, 10.0.16, 11.0.16
- Maven org.eclipse.jetty.ee9:jetty-ee9-servlets: affected <= 12.0.0-beta1; fixed in 12.0.0-beta2
- Maven org.eclipse.jetty.ee8:jetty-ee8-servlets: affected <= 12.0.0-beta1; fixed in 12.0.0-beta2
- Maven org.eclipse.jetty.ee10:jetty-ee10-servlets: affected <= 12.0.0-beta1; fixed in 12.0.0-beta2

## Suggested inspection (read-only)
- Maven org.eclipse.jetty:jetty-servlets: check the installed version with your package manager.
- Maven org.eclipse.jetty.ee9:jetty-ee9-servlets: check the installed version with your package manager.
- Maven org.eclipse.jetty.ee8:jetty-ee8-servlets: check the installed version with your package manager.
- Maven org.eclipse.jetty.ee10:jetty-ee10-servlets: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.eclipse.jetty:jetty-servlets, org.eclipse.jetty.ee9:jetty-ee9-servlets, org.eclipse.jetty.ee8:jetty-ee8-servlets, org.eclipse.jetty.ee10:jetty-ee10-servlets.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-3gh6-v5v9-6v9j (GitHub-reviewed advisory GHSA-3gh6-v5v9-6v9j lists affected ranges: Maven org.eclipse.jetty:jetty-servlets >=9.0.0 =10.0.0 =11.0.0 =0 =0 =0 <=12.0.0-beta1)

Commands are suggestions: review each one before running it.

Loading voting…