XWiki Platform vulnerable to persistent Cross-site Scripting through CKEditor Configuration pages
CVE-2023-36477GHSA-793w-g325-hrw2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.xwiki.contrib:application-ckeditor-ui 1.64.9; org.xwiki.platform:xwiki-platform-ckeditor-ui 15.1, 14.10.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.xwiki.contrib:application-ckeditor-ui
- Affected
- >= 1.9, < 1.64.9
- Fixed in
- 1.64.9
Maven org.xwiki.platform:xwiki-platform-ckeditor-ui
- Affected
- >= 14.6-rc-1, < 14.10.6>= 15.0-rc-1, < 15.1
- Fixed in
- 15.1, 14.10.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-793w-g325-hrw2 lists affected ranges: Maven org.xwiki.platform:xwiki-platform-ckeditor-ui >=14.6-rc-1 =15.0-rc-1 =1.9 <1.64.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.0 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H
- EPSS
- CVE-2023-36477: 0.90% estimated exploitation activity in the next 30 days; percentile 59.82 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Effect Any user with edit rights can edit all pages in the CKEditor' space. This makes it possible to perform a variety of harmful actions, such as - removing technical documents, leading to loss of service - Editing the javascript configuration of CKEditor, leading to persistent XSS Patches This issue has been patched in XWiki 14.10.6 and XWiki 15.1. This issue has been patched on the CKEditor Integration extension 1.64.9 for XWiki version older than 14.6RC1. Workarounds The issue can be fixed manually by restricting the edit and delete rights to a trusted user or group (e.g. the XWiki.XWikiAdminGroup group), implicitly disabling those rights for all other users. See https://github.com/xwiki/xwiki-platform/commit/9d9d86179457cb8dc48b4491510537878800be4f References - https://jira.xwiki.org/browse/XWIKI-20590 - https://jira.xwiki.org/browse/CKEDITOR-508 - https://github.com/xwiki/xwiki-platform/commit/9d9d86179457cb8dc48b4491510537878800be4f For more information If you have any…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-793w-g325-hrw2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-36477 Advisory: XWiki Platform vulnerable to persistent Cross-site Scripting through CKEditor Configuration pages IDs: CVE-2023-36477, GHSA-793w-g325-hrw2 Record: https://patchnext.com/advisories/cve-2023-36477 (revision 1, source checked 26 Oct 2026, 16:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.xwiki.contrib:application-ckeditor-ui 1.64.9; org.xwiki.platform:xwiki-platform-ckeditor-ui 15.1, 14.10.6. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.xwiki.contrib:application-ckeditor-ui: affected >= 1.9, < 1.64.9; fixed in 1.64.9 - Maven org.xwiki.platform:xwiki-platform-ckeditor-ui: affected >= 14.6-rc-1, < 14.10.6; >= 15.0-rc-1, < 15.1; fixed in 15.1, 14.10.6 ## Suggested inspection (read-only) - Maven org.xwiki.contrib:application-ckeditor-ui: check the installed version with your package manager. - Maven org.xwiki.platform:xwiki-platform-ckeditor-ui: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.xwiki.contrib:application-ckeditor-ui, org.xwiki.platform:xwiki-platform-ckeditor-ui. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-793w-g325-hrw2 (GitHub-reviewed advisory GHSA-793w-g325-hrw2 lists affected ranges: Maven org.xwiki.platform:xwiki-platform-ckeditor-ui >=14.6-rc-1 =15.0-rc-1 =1.9 <1.64.9) Commands are suggestions: review each one before running it.
Loading voting…