Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution
CVE-2023-36475GHSA-462x-c3jw-7vr6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (parse-server 6.2.1, 5.5.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm parse-server
- Affected
- < 5.5.2>= 6.0.0, < 6.2.1
- Fixed in
- 6.2.1, 5.5.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-462x-c3jw-7vr6 lists affected ranges: npm parse-server >=0 =6.0.0 <6.2.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-462x-c3jw-7vr6 lists affected ranges: npm parse-server >=0 =6.0.0 <6.2.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2023-36475: 3.20% estimated exploitation activity in the next 30 days; percentile 88.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact An attacker can use this prototype pollution sink to trigger a remote code execution through the MongoDB BSON parser. Patches Prevent prototype pollution in MongoDB database adapter. Workarounds Disable remote code execution through the MongoDB BSON parser. Credits - Discovered by hir0ot working with Trend Micro Zero Day Initiative - Fixed by dbythy - Reviewed by mtrezza References - https://github.com/parse-community/parse-server/security/advisories/GHSA-462x-c3jw-7vr6 - https://github.com/advisories/GHSA-prm5-8g2m-24gg
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-462x-c3jw-7vr6
- Revision 1 · created ·
Published from osv record GHSA-462x-c3jw-7vr6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-36475 Advisory: Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution IDs: CVE-2023-36475, GHSA-462x-c3jw-7vr6 Record: https://patchnext.com/advisories/cve-2023-36475 (revision 2, source checked 26 Oct 2026, 12:27 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: parse-server 6.2.1, 5.5.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm parse-server: affected < 5.5.2; >= 6.0.0, < 6.2.1; fixed in 6.2.1, 5.5.2 ## Suggested inspection (read-only) - `npm ls parse-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on parse-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-462x-c3jw-7vr6 (OSV record GHSA-462x-c3jw-7vr6 lists affected ranges: npm parse-server >=0 =6.0.0 <6.2.1 (fixed)) - Verified: https://github.com/advisories/GHSA-462x-c3jw-7vr6 (GitHub-reviewed advisory GHSA-462x-c3jw-7vr6 lists affected ranges: npm parse-server >=0 =6.0.0 <6.2.1) Commands are suggestions: review each one before running it.
Loading voting…