Skip to content

← Actionable
Medium, CVSS 5.8amended

Strapi may leak sensitive user information, user reset password, tokens via content-manager views

CVE-2023-36472GHSA-v8gg-4mq2-88q4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@strapi/utils 4.11.7; @strapi/admin 4.11.7; @strapi/plugin-content-manager 4.11.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.8 · CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:N/A:N
EPSS
  • CVE-2023-36472: 0.67% estimated exploitation activity in the next 30 days; percentile 52.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary I can get access to user reset password tokens if I have the configure view permissions Details /content-manager/relations route does not remove private fields or ensure that they can't be selected PoC Install fresh strapi instance start up strapi and create an account create a new content-type give the content-type a relation with admin users and save go to Admin panel roles Author and then plugins. Enable for content-manager collection types the configure view In the collection time now only give them access to the collection you created for this. Create a new admin user account with the Author role Log out and request a password reset for the main admin user. Login on the newly created account go to the collection type you created for this test and click the create new entry button, click in the create new entry view on configure view. select the admin user relation we created click on resetPasswordToken Now go back to the create an entry view and when selection the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-v8gg-4mq2-88q4

  2. Revision 1 · created ·

    Published from osv record GHSA-v8gg-4mq2-88q4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-36472

Advisory: Strapi may leak sensitive user information, user reset password, tokens via content-manager views
IDs: CVE-2023-36472, GHSA-v8gg-4mq2-88q4
Record: https://patchnext.com/advisories/cve-2023-36472 (revision 2, source checked 26 Oct 2026, 12:29 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @strapi/utils 4.11.7; @strapi/admin 4.11.7; @strapi/plugin-content-manager 4.11.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @strapi/utils: affected < 4.11.7; fixed in 4.11.7
- npm @strapi/admin: affected < 4.11.7; fixed in 4.11.7
- npm @strapi/plugin-content-manager: affected < 4.11.7; fixed in 4.11.7

## Suggested inspection (read-only)
- `npm ls @strapi/utils --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @strapi/admin --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @strapi/plugin-content-manager --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @strapi/utils, @strapi/admin, @strapi/plugin-content-manager.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-v8gg-4mq2-88q4 (OSV record GHSA-v8gg-4mq2-88q4 lists affected ranges: npm @strapi/plugin-content-manager >=0 =0 =0 <4.11.7 (fixed))
- Verified: https://github.com/advisories/GHSA-v8gg-4mq2-88q4 (GitHub-reviewed advisory GHSA-v8gg-4mq2-88q4 lists affected ranges: npm @strapi/plugin-content-manager >=0 =0 =0 <4.11.7)

Commands are suggestions: review each one before running it.

Loading voting…