Skip to content

← Actionable
Medium, CVSS 6.2amended

pypdf and PyPDF2 possible Infinite Loop when a comment isn't followed by a character

CVE-2023-36464GHSA-4vvm-4w3v-6mr8

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI pypdf

    Affected
    >= 3.1.0, < 3.9.0
    Fixed in
    3.9.0
  • PyPI pypdf2

    Affected
    >= 2.2.0, <= 3.0.1
    Fixed in
    no fixed version recorded

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.2 · CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2023-36464: 0.35% estimated exploitation activity in the next 30 days; percentile 28.95 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact An attacker who uses this vulnerability can craft a PDF which leads to an infinite loop if parsecontentstream is executed. This infinite loop blocks the current process and can utilize a single core of the CPU by 100%. It does not affect memory usage. That is, for example, the case if the user extracted text from such a PDF. Example Code and a PDF that causes the issue: The issue was introduced with https://github.com/py-pdf/pypdf/pull/969 Patches The issue was fixed with https://github.com/py-pdf/pypdf/pull/1828 Workarounds It is recommended to upgrade to pypdf=3.9.0. PyPDF2 users should migrate to pypdf. If you cannot update your version of pypdf, you should modify pypdf/generic/datastructures.py:

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-4vvm-4w3v-6mr8

  2. Revision 1 · created ·

    Published from osv record GHSA-4vvm-4w3v-6mr8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-36464

Advisory: pypdf and PyPDF2 possible Infinite Loop when a comment isn't followed by a character
IDs: CVE-2023-36464, GHSA-4vvm-4w3v-6mr8
Record: https://patchnext.com/advisories/cve-2023-36464 (revision 2, source checked 26 Oct 2026, 13:12 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: pypdf 3.9.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI pypdf: affected >= 3.1.0, < 3.9.0; fixed in 3.9.0
- PyPI pypdf2: affected >= 2.2.0, <= 3.0.1

## Suggested inspection (read-only)
- `python -m pip show pypdf`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show pypdf2`: prints the installed version. Run with the environment that serves production active.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pypdf, pypdf2.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-4vvm-4w3v-6mr8 (OSV record GHSA-4vvm-4w3v-6mr8 lists affected ranges: PyPI pypdf >=3.1.0 =2.2.0 <=3.0.1)
- Verified: https://github.com/advisories/GHSA-4vvm-4w3v-6mr8 (GitHub-reviewed advisory GHSA-4vvm-4w3v-6mr8 lists affected ranges: PyPI pypdf >=3.1.0 =2.2.0 <=3.0.1)

Commands are suggestions: review each one before running it.

Loading voting…