Skip to content

← Actionable
Medium, CVSS 6.1amended

yt-dlp File Downloader cookie leak

CVE-2023-35934GHSA-v8mc-9377-rwjj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (yt-dlp 2023.7.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI yt-dlp

    Affected
    < 2023.7.6
    Fixed in
    2023.7.6

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:N/A:N
EPSS
  • CVE-2023-35934: 1.05% estimated exploitation activity in the next 30 days; percentile 64.24 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact During file downloads, yt-dlp or the external downloaders that yt-dlp employs may leak cookies on HTTP redirects to a different host, or leak them when the host for download fragments differs from their parent manifest's host. This vulnerable behavior is present in all versions of youtube-dl, youtube-dlc and yt-dlp released since 2015.01.25. All native and external downloaders are affected, except for curl and httpie (httpie version 3.1.0 or later). At the file download stage, all cookies are passed by yt-dlp to the file downloader as a Cookie header, thereby losing their scope. This also occurs in yt-dlp's info JSON output, which may be used by external tools. As a result, the downloader or external tool may indiscriminately send cookies with requests to domains or paths for which the cookies are not scoped. An example of a potential attack scenario exploiting this vulnerability: 1. an attacker has crafted a malicious website with an embedded URL designed to be detected by…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-v8mc-9377-rwjj

  2. Revision 1 · created ·

    Published from osv record GHSA-v8mc-9377-rwjj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-35934

Advisory: yt-dlp File Downloader cookie leak
IDs: CVE-2023-35934, GHSA-v8mc-9377-rwjj
Record: https://patchnext.com/advisories/cve-2023-35934 (revision 2, source checked 26 Oct 2026, 13:12 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: yt-dlp 2023.7.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI yt-dlp: affected < 2023.7.6; fixed in 2023.7.6

## Suggested inspection (read-only)
- `python -m pip show yt-dlp`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on yt-dlp.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-v8mc-9377-rwjj (OSV record GHSA-v8mc-9377-rwjj lists affected ranges: PyPI yt-dlp >=0 <2023.7.06 (fixed))
- Verified: https://github.com/advisories/GHSA-v8mc-9377-rwjj (GitHub-reviewed advisory GHSA-v8mc-9377-rwjj lists affected ranges: PyPI yt-dlp >=0 <2023.7.6)

Commands are suggestions: review each one before running it.

Loading voting…