Skip to content

← Actionable
Medium, CVSS 5.9

OpenFGA vulnerable to denial of service due to circular relationship

CVE-2023-35933GHSA-hr9r-8phq-5x8j

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/openfga/openfga 1.1.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2023-35933: 1.13% estimated exploitation activity in the next 30 days; percentile 66.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Overview OpenFGA versions v1.1.0 and prior are vulnerable to a DoS attack when certain Check and ListObjects calls are executed against authorization models that contain circular relationship definitions. Am I Affected? You are affected by this vulnerability if you are using OpenFGA v1.1.0 or earlier, and if you are executing certain Check or ListObjects calls against a vulnerable authorization model. To see which of your models could be vulnerable to this attack, download OpenFGA v1.2.0 and run the following command: replacing the variables <ENGINE and <URI as needed. Fix Upgrade to v1.1.1. Backward Compatibility If you are not passing an invalid authorization model (as identified by running ./openfga validate-models) as a parameter of your Check and ListObjects calls, this upgrade is backwards compatible. Otherwise, OpenFGA v1.1.1 will start returning HTTP 400 status codes on those calls.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-hr9r-8phq-5x8j

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-35933

Advisory: OpenFGA vulnerable to denial of service due to circular relationship
IDs: CVE-2023-35933, GHSA-hr9r-8phq-5x8j
Record: https://patchnext.com/advisories/cve-2023-35933 (revision 1, source checked 26 Oct 2026, 14:59 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/openfga/openfga 1.1.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/openfga/openfga: affected < 1.1.1; fixed in 1.1.1

## Suggested inspection (read-only)
- Go github.com/openfga/openfga: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/openfga/openfga.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-hr9r-8phq-5x8j (GitHub-reviewed advisory GHSA-hr9r-8phq-5x8j lists affected ranges: Go github.com/openfga/openfga >=0 <1.1.1)

Commands are suggestions: review each one before running it.

Loading voting…