Backstage Scaffolder plugin has insecure sandbox
CVE-2023-35926GHSA-wg6p-jmpc-xjmr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@backstage/plugin-scaffolder-backend 1.15.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @backstage/plugin-scaffolder-backend
- Affected
- < 1.15.0
- Fixed in
- 1.15.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-wg6p-jmpc-xjmr lists affected ranges: npm @backstage/plugin-scaffolder-backend >=0 <1.15.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wg6p-jmpc-xjmr lists affected ranges: npm @backstage/plugin-scaffolder-backend >=0 <1.15.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.0 · CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2023-35926: 1.89% estimated exploitation activity in the next 30 days; percentile 79.56 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The Backstage scaffolder-backend plugin uses a templating library that requires a sandbox, as it by design allows for code injection. The library used for this sandbox so far has been vm2, but in light of several past vulnerabilities and existing vulnerabilities that may not have a fix, the plugin has switched to using a different sandbox library. Impact A malicious actor with write access to a registered scaffolder template could manipulate the template in a way that allows for remote code execution on the scaffolder-backend instance. This was only exploitable in the template YAML definition itself and not by user input data. Patches This is vulnerability is fixed in version 1.15.0 of @backstage/plugin-scaffolder-backend. Workarounds Note that the Backstage Threat Model states that scaffolder templates are considered to be a sensitive area that with the recommendation that you control access and perform manual reviews of changes to the scaffolder templates. The exploit is of a…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-wg6p-jmpc-xjmr
- Revision 1 · created ·
Published from osv record GHSA-wg6p-jmpc-xjmr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-35926 Advisory: Backstage Scaffolder plugin has insecure sandbox IDs: CVE-2023-35926, GHSA-wg6p-jmpc-xjmr Record: https://patchnext.com/advisories/cve-2023-35926 (revision 2, source checked 26 Oct 2026, 12:29 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @backstage/plugin-scaffolder-backend 1.15.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @backstage/plugin-scaffolder-backend: affected < 1.15.0; fixed in 1.15.0 ## Suggested inspection (read-only) - `npm ls @backstage/plugin-scaffolder-backend --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @backstage/plugin-scaffolder-backend. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-wg6p-jmpc-xjmr (OSV record GHSA-wg6p-jmpc-xjmr lists affected ranges: npm @backstage/plugin-scaffolder-backend >=0 <1.15.0 (fixed)) - Verified: https://github.com/advisories/GHSA-wg6p-jmpc-xjmr (GitHub-reviewed advisory GHSA-wg6p-jmpc-xjmr lists affected ranges: npm @backstage/plugin-scaffolder-backend >=0 <1.15.0) Commands are suggestions: review each one before running it.
Loading voting…