Apache Airflow ODBC Provider, Apache Airflow MSSQL Provider Improper Input Validation vulnerability
CVE-2023-35798GHSA-q57w-826p-46jr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (apache-airflow-providers-microsoft-mssql 3.4.1; apache-airflow-providers-odbc 4.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI apache-airflow-providers-microsoft-mssql
- Affected
- < 3.4.1
- Fixed in
- 3.4.1
PyPI apache-airflow-providers-odbc
- Affected
- < 4.0.0
- Fixed in
- 4.0.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-q57w-826p-46jr lists affected ranges: PyPI apache-airflow-providers-odbc >=0 =0 <3.4.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q57w-826p-46jr lists affected ranges: PyPI apache-airflow-providers-odbc >=0 =0 <3.4.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2023-35798: 1.26% estimated exploitation activity in the next 30 days; percentile 69.70 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Input Validation vulnerability in Apache Software Foundation Apache Airflow ODBC Provider, Apache Software Foundation Apache Airflow MSSQL Provider.This vulnerability is considered low since it requires DAG code to use getsqlalchemyconnection and someone with access to connection resources specifically updating the connection to exploit it. This issue affects Apache Airflow ODBC Provider: before 4.0.0; Apache Airflow MSSQL Provider: before 3.4.1. It is recommended to upgrade to a version that is not affected
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-q57w-826p-46jr
- Revision 1 · created ·
Published from osv record GHSA-q57w-826p-46jr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-35798 Advisory: Apache Airflow ODBC Provider, Apache Airflow MSSQL Provider Improper Input Validation vulnerability IDs: CVE-2023-35798, GHSA-q57w-826p-46jr Record: https://patchnext.com/advisories/cve-2023-35798 (revision 2, source checked 26 Oct 2026, 13:12 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: apache-airflow-providers-microsoft-mssql 3.4.1; apache-airflow-providers-odbc 4.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI apache-airflow-providers-microsoft-mssql: affected < 3.4.1; fixed in 3.4.1 - PyPI apache-airflow-providers-odbc: affected < 4.0.0; fixed in 4.0.0 ## Suggested inspection (read-only) - `python -m pip show apache-airflow-providers-microsoft-mssql`: prints the installed version. Run with the environment that serves production active. - `python -m pip show apache-airflow-providers-odbc`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on apache-airflow-providers-microsoft-mssql, apache-airflow-providers-odbc. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-q57w-826p-46jr (OSV record GHSA-q57w-826p-46jr lists affected ranges: PyPI apache-airflow-providers-odbc >=0 =0 <3.4.1 (fixed)) - Verified: https://github.com/advisories/GHSA-q57w-826p-46jr (GitHub-reviewed advisory GHSA-q57w-826p-46jr lists affected ranges: PyPI apache-airflow-providers-odbc >=0 =0 <3.4.1) Commands are suggestions: review each one before running it.
Loading voting…