Skip to content

← Actionable
Critical, CVSS 9.0

php-imap vulnerable to RCE through a directory traversal vulnerability

CVE-2023-35169GHSA-47p7-xfcc-4pv9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (webklex/laravel-imap 5.3.0; webklex/php-imap 5.3.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.0 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2023-35169: 3.19% estimated exploitation activity in the next 30 days; percentile 88.12 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary An unsanitized attachment filename allows any unauthenticated user to leverage a directory traversal vulnerability which results in a remote code execution vulnerability. Details An attacker can send an email with a malicious attachment to the inbox, which gets crawled with webklex/php-imap or webklex/laravel-imap. Prerequisite for the vulnerability is that the script stores the attachments without providing a $filename, or providing an unsanitized $filename, in src/Attachment::save(string $path, string $filename = null) (https://github.com/Webklex/php-imap/blob/5.2.0/src/Attachment.php#L251-L255). In this case, where no $filename gets passed into the Attachment::save() method, the package would use a series of unsanitized and insecure input values from the mail as fallback (https://github.com/Webklex/php-imap/blob/5.2.0/src/Attachment.php#L252). Even if a developer passes a $filename into the Attachment::save() method, e.g. by passing the name or filename of the mail…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-47p7-xfcc-4pv9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-35169

Advisory: php-imap vulnerable to RCE through a directory traversal vulnerability
IDs: CVE-2023-35169, GHSA-47p7-xfcc-4pv9
Record: https://patchnext.com/advisories/cve-2023-35169 (revision 1, source checked 26 Oct 2026, 14:10 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: webklex/laravel-imap 5.3.0; webklex/php-imap 5.3.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist webklex/laravel-imap: affected < 5.3.0; fixed in 5.3.0
- Packagist webklex/php-imap: affected < 5.3.0; fixed in 5.3.0

## Suggested inspection (read-only)
- Packagist webklex/laravel-imap: check the installed version with your package manager.
- Packagist webklex/php-imap: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on webklex/laravel-imap, webklex/php-imap.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-47p7-xfcc-4pv9 (GitHub-reviewed advisory GHSA-47p7-xfcc-4pv9 lists affected ranges: Packagist webklex/php-imap >=0 =0 <5.3.0)

Commands are suggestions: review each one before running it.

Loading voting…