AWS CDK EKS overly permissive trust policies
CVE-2023-35165GHSA-rx28-r23p-2qc3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (aws-cdk-lib 2.80.0; @aws-cdk/aws-eks 1.202.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm aws-cdk-lib
- Affected
- >= 2.0.0, < 2.80.0
- Fixed in
- 2.80.0
npm @aws-cdk/aws-eks
- Affected
- >= 1.57.0, < 1.202.0
- Fixed in
- 1.202.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-rx28-r23p-2qc3 lists affected ranges: npm aws-cdk-lib >=2.0.0 =1.57.0 <1.202.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rx28-r23p-2qc3 lists affected ranges: npm aws-cdk-lib >=2.0.0 =1.57.0 <1.202.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.6 · CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2023-35165: 0.90% estimated exploitation activity in the next 30 days; percentile 59.62 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
If you are using the eks.Cluster or eks.FargateCluster construct we need you to take action. Other users are not affected and can stop reading. Impact The AWS Cloud Development Kit (CDK) allows for the definition of Amazon Elastic Container Service for Kubernetes (EKS) clusters. eks.Cluster and eks.FargateCluster constructs create two roles that have an overly permissive trust policy. The first, referred to as the CreationRole, is used by lambda handlers to create the cluster and deploy Kubernetes resources (e.g KubernetesManifest, HelmChart, ...) onto it. Users with CDK version higher or equal to 1.62.0 (including v2 users) will be affected. The second, referred to as the default MastersRole, is provisioned only if the mastersRole property isn't provided and has permissions to execute kubectl commands on the cluster. Users with CDK version higher or equal to 1.57.0 (including v2 users) will be affected. Both these roles use the account root principal in their trust policy, which…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-rx28-r23p-2qc3
- Revision 1 · created ·
Published from osv record GHSA-rx28-r23p-2qc3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-35165 Advisory: AWS CDK EKS overly permissive trust policies IDs: CVE-2023-35165, GHSA-rx28-r23p-2qc3 Record: https://patchnext.com/advisories/cve-2023-35165 (revision 2, source checked 26 Oct 2026, 12:27 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: aws-cdk-lib 2.80.0; @aws-cdk/aws-eks 1.202.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm aws-cdk-lib: affected >= 2.0.0, < 2.80.0; fixed in 2.80.0 - npm @aws-cdk/aws-eks: affected >= 1.57.0, < 1.202.0; fixed in 1.202.0 ## Suggested inspection (read-only) - `npm ls aws-cdk-lib --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @aws-cdk/aws-eks --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on aws-cdk-lib, @aws-cdk/aws-eks. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-rx28-r23p-2qc3 (OSV record GHSA-rx28-r23p-2qc3 lists affected ranges: npm aws-cdk-lib >=2.0.0 =1.57.0 <1.202.0 (fixed)) - Verified: https://github.com/advisories/GHSA-rx28-r23p-2qc3 (GitHub-reviewed advisory GHSA-rx28-r23p-2qc3 lists affected ranges: npm aws-cdk-lib >=2.0.0 =1.57.0 <1.202.0) Commands are suggestions: review each one before running it.
Loading voting…