XWiki Platform vulnerable to reflected cross-site scripting via xredirect parameter in deletespace template
CVE-2023-35159GHSA-x234-mg7q-m8g8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.xwiki.platform:xwiki-platform-web-templates 15.1-rc-1, 14.10.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.xwiki.platform:xwiki-platform-web-templates
- Affected
- >= 3.4-milestone-1, < 14.10.5>= 15.0-rc-1, < 15.1-rc-1
- Fixed in
- 14.10.5, 15.1-rc-1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-x234-mg7q-m8g8 lists affected ranges: Maven org.xwiki.platform:xwiki-platform-web-templates >=3.4-milestone-1 =15.0-rc-1 <15.1-rc-1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
- EPSS
- CVE-2023-35159: 2.18% estimated exploitation activity in the next 30 days; percentile 82.39 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Users are able to forge an URL with a payload allowing to inject Javascript in the page (XSS). It's possible to exploit the deletespace template to perform a XSS, e.g. by using URL such as: xwiki/bin/deletespace/Sandbox/?xredirect=javascript:alert(document.domain) This vulnerability exists since XWiki 3.4-milestone-1. Patches The vulnerability has been patched in XWiki 14.10.5 and 15.1-rc-1. Workarounds It's possible to workaround the vulnerability by editing the template deletespace.vm to perform checks on it, but note that the appropriate fix involves new APIs that have been recently introduced in XWiki. See the referenced jira tickets. References Jira ticket about the vulnerability: https://jira.xwiki.org/browse/XWIKI-20612 Introduction of the macro used for fixing all those vulnerabilities: https://jira.xwiki.org/browse/XWIKI-20583 Commit containing the actual fix in the template: https://github.com/xwiki/xwiki-platform/commit/5c20ff5e3bdea50f1053fe99a27e011b8d0e4b34 For…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-x234-mg7q-m8g8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-35159 Advisory: XWiki Platform vulnerable to reflected cross-site scripting via xredirect parameter in deletespace template IDs: CVE-2023-35159, GHSA-x234-mg7q-m8g8 Record: https://patchnext.com/advisories/cve-2023-35159 (revision 1, source checked 26 Oct 2026, 16:19 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.xwiki.platform:xwiki-platform-web-templates 15.1-rc-1, 14.10.5. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.xwiki.platform:xwiki-platform-web-templates: affected >= 3.4-milestone-1, < 14.10.5; >= 15.0-rc-1, < 15.1-rc-1; fixed in 14.10.5, 15.1-rc-1 ## Suggested inspection (read-only) - Maven org.xwiki.platform:xwiki-platform-web-templates: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.xwiki.platform:xwiki-platform-web-templates. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-x234-mg7q-m8g8 (GitHub-reviewed advisory GHSA-x234-mg7q-m8g8 lists affected ranges: Maven org.xwiki.platform:xwiki-platform-web-templates >=3.4-milestone-1 =15.0-rc-1 <15.1-rc-1) Commands are suggestions: review each one before running it.
Loading voting…