SSL/TLS certificate validation disabled by default in Jenkins Checkmarx Plugin
CVE-2023-35142GHSA-rr3p-5fcf-v5m3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.checkmarx.jenkins:checkmarx 2023.2.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven com.checkmarx.jenkins:checkmarx
- Affected
- <= 2022.4.3
- Fixed in
- 2023.2.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rr3p-5fcf-v5m3 lists affected ranges: Maven com.checkmarx.jenkins:checkmarx >=0 <=2022.4.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2023-35142: 0.78% estimated exploitation activity in the next 30 days; percentile 55.81 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Jenkins Checkmarx Plugin 2022.4.3 and earlier disables SSL/TLS validation for connections to the Checkmarx server by default.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-rr3p-5fcf-v5m3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-35142 Advisory: SSL/TLS certificate validation disabled by default in Jenkins Checkmarx Plugin IDs: CVE-2023-35142, GHSA-rr3p-5fcf-v5m3 Record: https://patchnext.com/advisories/cve-2023-35142 (revision 1, source checked 26 Oct 2026, 16:26 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: com.checkmarx.jenkins:checkmarx 2023.2.6. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven com.checkmarx.jenkins:checkmarx: affected <= 2022.4.3; fixed in 2023.2.6 ## Suggested inspection (read-only) - Maven com.checkmarx.jenkins:checkmarx: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on com.checkmarx.jenkins:checkmarx. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-rr3p-5fcf-v5m3 (GitHub-reviewed advisory GHSA-rr3p-5fcf-v5m3 lists affected ranges: Maven com.checkmarx.jenkins:checkmarx >=0 <=2022.4.3) Commands are suggestions: review each one before running it.
Loading voting…