Skip to content

← Actionable
Critical, CVSS 9.0

XWiki vulnerable to stored cross-site scripting via any wiki document and the displaycontent/rendercontent template

CVE-2023-34464GHSA-fp7h-f9f5-x4q7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.xwiki.platform:xwiki-platform-web 14.4.8; org.xwiki.platform:xwiki-platform-web-templates 15.1-rc-1, 14.10.5, 14.4.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.0 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H
EPSS
  • CVE-2023-34464: 0.71% estimated exploitation activity in the next 30 days; percentile 53.75 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Any user who can edit a document in a wiki like the user profile can create a stored XSS attack by putting plain HTML code into that document and then tricking another user to visit that document with the displaycontent or rendercontent template and plain output syntax. For example, edit any document with the wiki editor and set the content to <scriptalert(1)</script , save and then append the parameters ?viewer=displaycontent&sheet=&outputSyntax=plain. If this displays an alert, the installation is vulnerable. If a user with programming rights is tricked into visiting such a URL, arbitrary actions be performed with this user's rights, impacting the confidentiality, integrity, and availability of the whole XWiki installation. Patches This has been patched in XWiki 14.4.8, 14.10.5 and 15.1RC1 by setting the content type of the response to plain text when the output syntax is not an HTML syntax. Workarounds The patch can be manually applied to the rendercontent.vm template in an…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-fp7h-f9f5-x4q7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-34464

Advisory: XWiki vulnerable to stored cross-site scripting via any wiki document and the displaycontent/rendercontent template
IDs: CVE-2023-34464, GHSA-fp7h-f9f5-x4q7
Record: https://patchnext.com/advisories/cve-2023-34464 (revision 1, source checked 26 Oct 2026, 16:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.xwiki.platform:xwiki-platform-web 14.4.8; org.xwiki.platform:xwiki-platform-web-templates 15.1-rc-1, 14.10.5, 14.4.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.xwiki.platform:xwiki-platform-web: affected >= 2.2.1, < 14.4.8; fixed in 14.4.8
- Maven org.xwiki.platform:xwiki-platform-web-templates: affected < 14.4.8; >= 14.5, < 14.10.5; >= 15.0-rc-1, < 15.1-rc-1; fixed in 14.10.5, 15.1-rc-1, 14.4.8

## Suggested inspection (read-only)
- Maven org.xwiki.platform:xwiki-platform-web: check the installed version with your package manager.
- Maven org.xwiki.platform:xwiki-platform-web-templates: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.xwiki.platform:xwiki-platform-web, org.xwiki.platform:xwiki-platform-web-templates.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-fp7h-f9f5-x4q7 (GitHub-reviewed advisory GHSA-fp7h-f9f5-x4q7 lists affected ranges: Maven org.xwiki.platform:xwiki-platform-web >=2.2.1 =0 =14.5 =15.0-rc-1 <15.1-rc-1)

Commands are suggestions: review each one before running it.

Loading voting…