OpenZeppelin Contracts using MerkleProof multiproofs may allow proving arbitrary leaves for specific trees
CVE-2023-34459GHSA-wprv-93r4-jj2p
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@openzeppelin/contracts 4.9.2; @openzeppelin/contracts-upgradeable 4.9.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 4.7.0, < 4.9.2
- Fixed in
- 4.9.2
npm @openzeppelin/contracts-upgradeable
- Affected
- >= 4.7.0, < 4.9.2
- Fixed in
- 4.9.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-wprv-93r4-jj2p lists affected ranges: npm @openzeppelin/contracts >=4.7.0 =4.7.0 <4.9.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wprv-93r4-jj2p lists affected ranges: npm @openzeppelin/contracts >=4.7.0 =4.7.0 <4.9.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2023-34459: 0.37% estimated exploitation activity in the next 30 days; percentile 31.06 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact When the verifyMultiProof, verifyMultiProofCalldata, processMultiProof, or processMultiProofCalldata functions are in use, it is possible to construct merkle trees that allow forging a valid multiproof for an arbitrary set of leaves. A contract may be vulnerable if it uses multiproofs for verification and the merkle tree that is processed includes a node with value 0 at depth 1 (just under the root). This could happen inadvertently for balanced trees with 3 leaves or less, if the leaves are not hashed. This could happen deliberately if a malicious tree builder includes such a node in the tree. A contract is not vulnerable if it uses single-leaf proving (verify, verifyCalldata, processProof, or processProofCalldata), or if it uses multiproofs with a known tree that has hashed leaves. Standard merkle trees produced or validated with the @openzeppelin/merkle-tree library are safe. Patches The problem has been patched in 4.9.2. Workarounds If you are using multiproofs: When…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-wprv-93r4-jj2p
- Revision 1 · created ·
Published from osv record GHSA-wprv-93r4-jj2p
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-34459 Advisory: OpenZeppelin Contracts using MerkleProof multiproofs may allow proving arbitrary leaves for specific trees IDs: CVE-2023-34459, GHSA-wprv-93r4-jj2p Record: https://patchnext.com/advisories/cve-2023-34459 (revision 2, source checked 26 Oct 2026, 12:27 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @openzeppelin/contracts 4.9.2; @openzeppelin/contracts-upgradeable 4.9.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @openzeppelin/contracts: affected >= 4.7.0, < 4.9.2; fixed in 4.9.2 - npm @openzeppelin/contracts-upgradeable: affected >= 4.7.0, < 4.9.2; fixed in 4.9.2 ## Suggested inspection (read-only) - `npm ls @openzeppelin/contracts --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @openzeppelin/contracts-upgradeable --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @openzeppelin/contracts, @openzeppelin/contracts-upgradeable. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-wprv-93r4-jj2p (OSV record GHSA-wprv-93r4-jj2p lists affected ranges: npm @openzeppelin/contracts >=4.7.0 =4.7.0 <4.9.2 (fixed)) - Verified: https://github.com/advisories/GHSA-wprv-93r4-jj2p (GitHub-reviewed advisory GHSA-wprv-93r4-jj2p lists affected ranges: npm @openzeppelin/contracts >=4.7.0 =4.7.0 <4.9.2) Commands are suggestions: review each one before running it.
Loading voting…