snappy-java's Integer Overflow vulnerability in shuffle leads to DoS
CVE-2023-34453GHSA-pqr6-cmr2-h8hf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.xerial.snappy:snappy-java 1.1.10.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.xerial.snappy:snappy-java
- Affected
- <= 1.1.10.0
- Fixed in
- 1.1.10.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pqr6-cmr2-h8hf lists affected ranges: Maven org.xerial.snappy:snappy-java >=0 <=1.1.10.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2023-34453: 1.71% estimated exploitation activity in the next 30 days; percentile 77.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Due to unchecked multiplications, an integer overflow may occur, causing a fatal error. Impact Denial of Service Description The function [shuffle(int[] input)](https://github.com/xerial/snappy-java/blob/05c39b2ca9b5b7b39611529cc302d3d796329611/src/main/java/org/xerial/snappy/BitShuffle.java#L107) in the file BitShuffle.java receives an array of integers and applies a bit shuffle on it. It does so by multiplying the length by 4 and passing it to the natively compiled shuffle function. Since the length is not tested, the multiplication by four can cause an integer overflow and become a smaller value than the true size, or even zero or negative. In the case of a negative value, a “java.lang.NegativeArraySizeException” exception will raise, which can crash the program. In a case of a value that is zero or too small, the code that afterwards references the shuffled array will assume a bigger size of the array, which might cause exceptions such as…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-pqr6-cmr2-h8hf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-34453 Advisory: snappy-java's Integer Overflow vulnerability in shuffle leads to DoS IDs: CVE-2023-34453, GHSA-pqr6-cmr2-h8hf Record: https://patchnext.com/advisories/cve-2023-34453 (revision 1, source checked 26 Oct 2026, 16:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.xerial.snappy:snappy-java 1.1.10.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.xerial.snappy:snappy-java: affected <= 1.1.10.0; fixed in 1.1.10.1 ## Suggested inspection (read-only) - Maven org.xerial.snappy:snappy-java: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.xerial.snappy:snappy-java. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-pqr6-cmr2-h8hf (GitHub-reviewed advisory GHSA-pqr6-cmr2-h8hf lists affected ranges: Maven org.xerial.snappy:snappy-java >=0 <=1.1.10.0) Commands are suggestions: review each one before running it.
Loading voting…