Grav Server-side Template Injection (SSTI) via Twig Default Filters
CVE-2023-34448GHSA-whr7-m3f8-mpm8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (getgrav/grav 1.7.42), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist getgrav/grav
- Affected
- < 1.7.42
- Fixed in
- 1.7.42
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-whr7-m3f8-mpm8 lists affected ranges: Packagist getgrav/grav >=0 <1.7.42
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.2 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2023-34448: 4.52% estimated exploitation activity in the next 30 days; percentile 91.54 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Hi, actually we have sent the bug report to security@getgrav.org on 27th March 2023 and on 10th April 2023. Grav Server-side Template Injection (SSTI) via Twig Default Filters Summary: | Product | Grav CMS | | ----------------------- | --------------------------------------------- | | Vendor | Grav | | Severity | High - Users with login access to Grav Admin panel and page creation/update permissions are able to obtain remote code/command execution | | Affected Versions | <= v1.7.40 (Commit 685d762) (Latest version as of writing) | | Tested Versions | v1.7.40 | | Internal Identifier | STAR-2023-0008 | | CVE Identifier | TBD | | CWE(s) | CWE-184: Incomplete List of Disallowed Inputs, CWE-1336: Improper Neutralization of Special Elements Used in a Template Engine | CVSS3.1 Scoring System: Base Score: 7.2 (High) Vector String: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H | Metric | Value | | ---------------------------- | --------- | | Attack Vector (AV) | Network | | Attack Complexity…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-whr7-m3f8-mpm8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-34448 Advisory: Grav Server-side Template Injection (SSTI) via Twig Default Filters IDs: CVE-2023-34448, GHSA-whr7-m3f8-mpm8 Record: https://patchnext.com/advisories/cve-2023-34448 (revision 1, source checked 26 Oct 2026, 14:10 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: getgrav/grav 1.7.42. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist getgrav/grav: affected < 1.7.42; fixed in 1.7.42 ## Suggested inspection (read-only) - Packagist getgrav/grav: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on getgrav/grav. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-whr7-m3f8-mpm8 (GitHub-reviewed advisory GHSA-whr7-m3f8-mpm8 lists affected ranges: Packagist getgrav/grav >=0 <1.7.42) Commands are suggestions: review each one before running it.
Loading voting…