Skip to content

← Actionable
Medium, CVSS 4.2

Doorkeeper Improper Authentication vulnerability

CVE-2023-34246GHSA-7w2c-w47h-789w

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (doorkeeper 5.6.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.2 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:N
EPSS
  • CVE-2023-34246: 0.72% estimated exploitation activity in the next 30 days; percentile 53.83 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

OAuth RFC 8252 says https://www.rfc-editor.org/rfc/rfc8252#section-8.6 the authorization server SHOULD NOT process authorization requests automatically without user consent or interaction, except when the identity of the client can be assured. This includes the case where the user has previously approved an authorization request for a given client id But Doorkeeper automatically processes authorization requests without user consent for public clients that have been previously approved. Public clients are inherently vulnerable to impersonation, their identity cannot be assured. Issue https://github.com/doorkeeper-gem/doorkeeper/issues/1589 Fix https://github.com/doorkeeper-gem/doorkeeper/pull/1646

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-7w2c-w47h-789w

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-34246

Advisory: Doorkeeper Improper Authentication vulnerability
IDs: CVE-2023-34246, GHSA-7w2c-w47h-789w
Record: https://patchnext.com/advisories/cve-2023-34246 (revision 1, source checked 26 Oct 2026, 15:48 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: doorkeeper 5.6.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems doorkeeper: affected < 5.6.6; fixed in 5.6.6

## Suggested inspection (read-only)
- RubyGems doorkeeper: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on doorkeeper.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-7w2c-w47h-789w (GitHub-reviewed advisory GHSA-7w2c-w47h-789w lists affected ranges: RubyGems doorkeeper >=0 <5.6.6)

Commands are suggestions: review each one before running it.

Loading voting…