@udecode/plate-link does not sanitize URLs to prevent use of the javascript: scheme
CVE-2023-34245GHSA-4882-hxpr-hrvm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@udecode/plate-link 20.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 20.0.0
- Fixed in
- 20.0.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-4882-hxpr-hrvm lists affected ranges: npm @udecode/plate-link >=0 <20.0.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4882-hxpr-hrvm lists affected ranges: npm @udecode/plate-link >=0 <20.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N
- EPSS
- CVE-2023-34245: 0.45% estimated exploitation activity in the next 30 days; percentile 38.75 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Affected versions of the link plugin and link UI component do not sanitize URLs to prevent use of the javascript: scheme. As a result, links with JavaScript URLs can be inserted into the Plate editor through various means, including opening or pasting malicious content. Patches @udecode/plate-link 20.0.0 resolves this issue by introducing an allowedSchemes option to the link plugin, defaulting to ['http', 'https', 'mailto', 'tel']. URLs using a scheme that isn't in this list will not be rendered to the DOM. Workarounds If you are unable to update @udecode/plate-link to version 20.0.0, we recommend overriding the LinkElement and PlateFloatingLink components with implementations that explicitly check the URL scheme before rendering any anchor elements.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-4882-hxpr-hrvm
- Revision 1 · created ·
Published from osv record GHSA-4882-hxpr-hrvm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-34245 Advisory: @udecode/plate-link does not sanitize URLs to prevent use of the `javascript:` scheme IDs: CVE-2023-34245, GHSA-4882-hxpr-hrvm Record: https://patchnext.com/advisories/cve-2023-34245 (revision 2, source checked 26 Oct 2026, 12:29 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @udecode/plate-link 20.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @udecode/plate-link: affected < 20.0.0; fixed in 20.0.0 ## Suggested inspection (read-only) - `npm ls @udecode/plate-link --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @udecode/plate-link. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-4882-hxpr-hrvm (OSV record GHSA-4882-hxpr-hrvm lists affected ranges: npm @udecode/plate-link >=0 <20.0.0 (fixed)) - Verified: https://github.com/advisories/GHSA-4882-hxpr-hrvm (GitHub-reviewed advisory GHSA-4882-hxpr-hrvm lists affected ranges: npm @udecode/plate-link >=0 <20.0.0) Commands are suggestions: review each one before running it.
Loading voting…