Skip to content

← Actionable
High, CVSS 8.6amended

Leaking sensitive user information still possible by filtering on private with prefix fields

CVE-2023-34235GHSA-9xg4-3qfm-9w8f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@strapi/utils 4.10.8; @strapi/database 4.10.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N
EPSS
  • CVE-2023-34235: 1.09% estimated exploitation activity in the next 30 days; percentile 65.58 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Still able to leak private fields if using the t(number) prefix Details Knex query allows you to change there default prefix so if you change the prefix to the same as it was before or to an other table you want to query you query changes from password to t1.password password is protected by filtering protections but t1.password is not protected PoC 1 Create a contentType 2 add to its options "populateCreatorFields" 3 create 1 entity in your new content type 4 in settings enable the find route in settings for the content type you created for public 5 /api/(Your contenttype)?filters%5BupdatedBy%5D%5Bt1.password%5D%5B%24startsWith%5D=a%24 And now the api returns noting if you were to do /api/(Your contenttype)?filters%5BupdatedBy%5D%5Bt1.password%5D%5B%24startsWith%5D=%24 it would return your entity Impact You can do filtering attacks on everything related to the object again including admin passwords and reset-tokens.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-9xg4-3qfm-9w8f

  2. Revision 1 · created ·

    Published from osv record GHSA-9xg4-3qfm-9w8f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-34235

Advisory: Leaking sensitive user information still possible by filtering on private with prefix fields
IDs: CVE-2023-34235, GHSA-9xg4-3qfm-9w8f
Record: https://patchnext.com/advisories/cve-2023-34235 (revision 2, source checked 26 Oct 2026, 12:27 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @strapi/utils 4.10.8; @strapi/database 4.10.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @strapi/utils: affected <= 4.10.7; fixed in 4.10.8
- npm @strapi/database: affected <= 4.10.7; fixed in 4.10.8

## Suggested inspection (read-only)
- `npm ls @strapi/utils --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @strapi/database --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @strapi/utils, @strapi/database.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-9xg4-3qfm-9w8f (OSV record GHSA-9xg4-3qfm-9w8f lists affected ranges: npm @strapi/database >=0 =0 <4.10.8 (fixed))
- Verified: https://github.com/advisories/GHSA-9xg4-3qfm-9w8f (GitHub-reviewed advisory GHSA-9xg4-3qfm-9w8f lists affected ranges: npm @strapi/database >=0 =0 <=4.10.7)

Commands are suggestions: review each one before running it.

Loading voting…