Skip to content

← Actionable
High, CVSS 8.5amended

Snowflake Python Connector vulnerable to Command Injection

CVE-2023-34233GHSA-5w5m-pfw9-c8fp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (snowflake-connector-python 3.0.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.5 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2023-34233: 1.84% estimated exploitation activity in the next 30 days; percentile 79.03 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Issue Snowflake was informed via our bug bounty program of a command injection vulnerability in the Snowflake Python connector via SSO browser URL authentication. Impacted driver package: snowflake-connector-python Impacted version range: before Version 3.0.2 Attack Scenario In order to exploit the potential for command injection, an attacker would need to be successful in (1) establishing a malicious resource and (2) redirecting users to utilize the resource. The attacker could set up a malicious, publicly accessible server which responds to the SSO URL with an attack payload. If the attacker then tricked a user into visiting the maliciously crafted connection URL, the user’s local machine would render the malicious payload, leading to a remote code execution. This attack scenario can be mitigated through URL whitelisting as well as common anti-phishing resources. Solution On March 23rd, 2023, Snowflake merged a patch that fixed a command injection vulnerability in the Snowflake…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-5w5m-pfw9-c8fp

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-5w5m-pfw9-c8fp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-34233

Advisory: Snowflake Python Connector vulnerable to Command Injection
IDs: CVE-2023-34233, GHSA-5w5m-pfw9-c8fp
Record: https://patchnext.com/advisories/cve-2023-34233 (revision 3, source checked 26 Oct 2026, 13:25 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: snowflake-connector-python 3.0.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI snowflake-connector-python: affected < 3.0.2; fixed in 3.0.2

## Suggested inspection (read-only)
- `python -m pip show snowflake-connector-python`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on snowflake-connector-python.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-5w5m-pfw9-c8fp (OSV record GHSA-5w5m-pfw9-c8fp lists affected ranges: PyPI snowflake-connector-python >=0 <3.0.2 (fixed))
- Verified: https://github.com/advisories/GHSA-5w5m-pfw9-c8fp (GitHub-reviewed advisory GHSA-5w5m-pfw9-c8fp lists affected ranges: PyPI snowflake-connector-python >=0 <3.0.2)

Commands are suggestions: review each one before running it.

Loading voting…