Snowflake NodeJS Driver vulnerable to Command Injection
CVE-2023-34232GHSA-h53w-7qw7-vh5c
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (snowflake-sdk 1.6.21), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm snowflake-sdk
- Affected
- < 1.6.21
- Fixed in
- 1.6.21
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-h53w-7qw7-vh5c lists affected ranges: npm snowflake-sdk >=0 <1.6.21 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-h53w-7qw7-vh5c lists affected ranges: npm snowflake-sdk >=0 <1.6.21
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N
- EPSS
- CVE-2023-34232: 1.90% estimated exploitation activity in the next 30 days; percentile 79.67 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Issue Snowflake was informed via our bug bounty program of a command injection vulnerability in the Snowflake NodeJS driver via SSO browser URL authentication. Impacted driver package: snowflake-connector-nodejs Impacted version range: before Version 1.6.21 Attack Scenario In order to exploit the potential for command injection, an attacker would need to be successful in (1) establishing a malicious resource and (2) redirecting users to utilize the resource. The attacker could set up a malicious, publicly accessible server which responds to the SSO URL with an attack payload. If the attacker then tricked a user into visiting the maliciously crafted connection URL, the user’s local machine would render the malicious payload, leading to a remote code execution. This attack scenario can be mitigated through URL whitelisting as well as common anti-phishing resources. Solution On April 18, 2023, Snowflake merged a patch that fixed a command injection vulnerability in the Snowflake NodeJS…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-h53w-7qw7-vh5c
- Revision 1 · created ·
Published from osv record GHSA-h53w-7qw7-vh5c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-34232 Advisory: Snowflake NodeJS Driver vulnerable to Command Injection IDs: CVE-2023-34232, GHSA-h53w-7qw7-vh5c Record: https://patchnext.com/advisories/cve-2023-34232 (revision 2, source checked 26 Oct 2026, 12:27 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: snowflake-sdk 1.6.21. A vendor fix does not mean a deployment is fixed. ## Affected components - npm snowflake-sdk: affected < 1.6.21; fixed in 1.6.21 ## Suggested inspection (read-only) - `npm ls snowflake-sdk --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on snowflake-sdk. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-h53w-7qw7-vh5c (OSV record GHSA-h53w-7qw7-vh5c lists affected ranges: npm snowflake-sdk >=0 <1.6.21 (fixed)) - Verified: https://github.com/advisories/GHSA-h53w-7qw7-vh5c (GitHub-reviewed advisory GHSA-h53w-7qw7-vh5c lists affected ranges: npm snowflake-sdk >=0 <1.6.21) Commands are suggestions: review each one before running it.
Loading voting…