Skip to content

← Actionable
High, CVSS 7.3

Snowflake Golang Driver vulnerable to Command Injection

CVE-2023-34231GHSA-fwv2-65wh-2w8c

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/snowflakedb/gosnowflake 1.6.19), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N
EPSS
  • CVE-2023-34231: 1.96% estimated exploitation activity in the next 30 days; percentile 80.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Issue Snowflake was informed via our bug bounty program of a command injection vulnerability in the Snowflake Golang driver via SSO browser URL authentication. Impacted driver package: gosnowflake Impacted version range: before Version 1.6.19 Attack Scenario In order to exploit the potential for command injection, an attacker would need to be successful in (1) establishing a malicious resource and (2) redirecting users to utilize the resource. The attacker could set up a malicious, publicly accessible server which responds to the SSO URL with an attack payload. If the attacker then tricked a user into visiting the maliciously crafted connection URL, the user’s local machine would render the malicious payload, leading to a remote code execution. This attack scenario can be mitigated through URL whitelisting as well as common anti-phishing resources. Solution On March 21, 2023, Snowflake merged a patch that fixed a command injection vulnerability in the Snowflake Golang driver via SSO…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-fwv2-65wh-2w8c

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-34231

Advisory: Snowflake Golang Driver vulnerable to Command Injection
IDs: CVE-2023-34231, GHSA-fwv2-65wh-2w8c
Record: https://patchnext.com/advisories/cve-2023-34231 (revision 1, source checked 26 Oct 2026, 14:59 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/snowflakedb/gosnowflake 1.6.19. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/snowflakedb/gosnowflake: affected < 1.6.19; fixed in 1.6.19

## Suggested inspection (read-only)
- Go github.com/snowflakedb/gosnowflake: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/snowflakedb/gosnowflake.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-fwv2-65wh-2w8c (GitHub-reviewed advisory GHSA-fwv2-65wh-2w8c lists affected ranges: Go github.com/snowflakedb/gosnowflake >=0 <1.6.19)

Commands are suggestions: review each one before running it.

Loading voting…